diff mbox series

[bug#55580] gnu: Add python-langcodes

Message ID 8735ggz37k.fsf@gmail.com
State Accepted
Headers show
Series [bug#55580] gnu: Add python-langcodes | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov June 7, 2022, 7:24 p.m. UTC
Oh, I forgot to remote 'python' from inputs.

Please find double-fixed patch attached.

- Artyom

Comments

Artyom V. Poptsov June 13, 2022, 9:13 a.m. UTC | #1
Hello Mathieu,

have you had any chance to review my updated patch?

Thanks!

- Artyom
Ludovic Courtès June 13, 2022, 10:28 a.m. UTC | #2
Hi,

"Artyom V. Poptsov" <poptsov.artyom@gmail.com> skribis:

> From 1e6e6361d3c4cb007f8cd160797b8c4a1f7aacdc Mon Sep 17 00:00:00 2001
> From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
> Date: Sun, 22 May 2022 21:50:37 +0300
> Subject: [PATCH] gnu: Add python-langcodes
>
> * gnu/packages/python-xyz.scm (python-langcodes): New variable.

I made the beginning of the description a sentence and committed it.

Thanks,
Ludo’.
diff mbox series

Patch

From 1e6e6361d3c4cb007f8cd160797b8c4a1f7aacdc Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 22 May 2022 21:50:37 +0300
Subject: [PATCH] gnu: Add python-langcodes

* gnu/packages/python-xyz.scm (python-langcodes): New variable.
---
 gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f3d7fab973..628bce5d8f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29403,3 +29403,31 @@  Information about these scales can be
 @url{https://en.wikipedia.org/wiki/List_of_musical_scales_and_modes, found on
 Wikipedia}.")
     (license license:expat)))
+
+(define-public python-langcodes
+  (package
+    (name "python-langcodes")
+    (version "3.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "langcodes" version))
+              (sha256
+               (base32
+                "1xkyh3qdcigb18qiimbwl2669y22hhdmd89mqcd270c7lbahfkbr"))))
+    (build-system python-build-system)
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/rspeer/langcodes")
+    (synopsis "Python library for working with language codes")
+    (description
+     "A Python library for working with and comparing language codes.
+
+@code{python-langcodes} implements @url{http://tools.ietf.org/html/bcp47, BCP
+47}, the IETF Best Current Practices on Tags for Identifying Languages.  BCP
+47 is also known as RFC 5646.  It subsumes ISO 639 and is backward compatible
+with it, and it also implements recommendations from the
+@url{http://cldr.unicode.org/, Unicode CLDR}.
+
+@code{python-langcodes} can also refer to a database of language properties
+and names, built from Unicode CLDR and the IANA subtag registry, if you
+install @code{python-language-data}.")
+    (license license:expat)))
-- 
2.25.1