diff mbox series

[bug#57311] gnu: Add snapper.

Message ID 8735dqmw72.fsf@ngraves.fr
State New
Headers show
Series [bug#57311] gnu: Add snapper. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Aug. 20, 2022, 9:39 p.m. UTC
* gnu/packages/file-systems.scm (snapper): New variable.
---
 gnu/packages/file-systems.scm | 66 +++++++++++++++++++++++++++++++++++
 1 file changed, 66 insertions(+)

--
2.37.2

Comments

Nicolas Graves Feb. 10, 2023, 4:43 p.m. UTC | #1
Quick reminder for this forgotten patch ;)
Hartmut Goebel Feb. 16, 2024, 9:06 p.m. UTC | #2
user guix
usertag 57311 + reviewed-looks-good
thanks

Guix QA review form submission:
- If this is btrfs-only, the synobsis should mention btrfs.
- Please re-wrap the desription to not have an escaped newline. Start 
text jsut after opening quote.

Items marked as checked: Package builds, Commit messages, New package 
licenses, New package tests
diff mbox series

Patch

diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index d326b9cc3d..41f03f686f 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -49,6 +49,7 @@  (define-module (gnu packages file-systems)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
+  #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages crypto)
@@ -59,6 +60,7 @@  (define-module (gnu packages file-systems)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages gawk)
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages golang)
@@ -66,6 +68,8 @@  (define-module (gnu packages file-systems)
   #:use-module (gnu packages kerberos)
   #:use-module (gnu packages libffi)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages m4)
+  #:use-module (gnu packages ncurses)
   #:use-module (gnu packages nfs)
   #:use-module (gnu packages onc-rpc)
   #:use-module (gnu packages openldap)
@@ -85,6 +89,7 @@  (define-module (gnu packages file-systems)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages valgrind)
   #:use-module (gnu packages version-control)
+  #:use-module (gnu packages web)
   #:use-module (gnu packages xml))

 (define-public autofs
@@ -1539,6 +1544,67 @@  (define-public python-dropbox
 Dropbox API v2.")
     (license license:expat)))

+(define-public snapper
+  (package
+    (name "snapper")
+    (version "0.10.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/openSUSE/snapper")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0x9anracaa19yqkc0x8wangrkdrx01kdy07c55lvlqrjyimfm4ih"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           (delete-file-recursively "dists")
+           (delete-file-recursively "zypp-plugin")
+           (substitute* '("configure.ac" "doc/Makefile.am")
+             ((".*dists.*") "")
+             ((".*zypp-plugin.*") ""))
+           (substitute* "Makefile.am"
+             (("zypp-plugin") ""))))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'relative-file-locations
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out")))
+               (substitute* (list "scripts/Makefile.am" "data/Makefile.am")
+                 (("/usr/share") (string-append out "/share"))
+                 (("/usr/lib") (string-append out "/lib"))
+                 (("/etc/") (string-append out "/etc/"))))
+               (substitute* "client/Makefile.am"
+                 (("/usr/lib") "@libdir@")))))))
+    (home-page "https://snapper.io")
+    (native-inputs
+     (list glibc-locales autoconf automake libtool pkg-config dbus))
+    (inputs
+    `(("btrfs" ,btrfs-progs)
+      ("e2fs" ,e2fsprogs)
+      ("libmount" ,util-linux "lib")
+      ("dbus" ,dbus)
+      ("libxml" ,libxml2)
+      ("json-c" ,json-c)
+      ("libacl" ,acl)
+      ("boost" ,boost)
+      ("libxslt" ,libxslt)
+      ("docbook-xsl" ,docbook-xsl)
+      ("gettext" ,gettext-minimal)
+      ("pam" ,linux-pam)
+      ("ncurses" ,ncurses/tinfo)))
+    (synopsis "Manage filesystem snapshots and allow roll-backs")
+    (description "\
+This package provides Snapper, a tool that helps with managing
+snapshots of Btrfs subvolumes and thin-provisioned LVM volumes.  It
+can create and compare snapshots, revert differences between them, and
+supports automatic snapshots timelines.")
+    (license license:gpl2)))
+
 (define-public dbxfs
   (package
     (name "dbxfs")