diff mbox series

[bug#60593] gnu: picom: Update to 10.2.

Message ID 87358ojiw2.fsf@protonmail.com
State New
Headers show
Series [bug#60593] gnu: picom: Update to 10.2. | expand

Commit Message

John Kehayias Jan. 6, 2023, 6:07 a.m. UTC
Hi Guix,

Here's a patch to update picom to the latest release. An autostart file was added, which needs to be patched for the 'Exec' lines (the patch desktop files phase only looks in share/applications). Checked that it builds, lints, runs.

John

Comments

Mathieu Othacehe Jan. 8, 2023, 1:34 p.m. UTC | #1
Hello John,

> Here's a patch to update picom to the latest release. An autostart
> file was added, which needs to be patched for the 'Exec' lines (the
> patch desktop files phase only looks in share/applications). Checked
> that it builds, lints, runs.

This looks fine, please go ahead!

Mathieu
John Kehayias Jan. 13, 2023, 6:55 p.m. UTC | #2
Hello Mathieu,

On Sun, Jan 08, 2023 at 02:34 PM, Mathieu Othacehe wrote:

> Hello John,
>
>> Here's a patch to update picom to the latest release. An autostart
>> file was added, which needs to be patched for the 'Exec' lines (the
>> patch desktop files phase only looks in share/applications). Checked
>> that it builds, lints, runs.
>
> This looks fine, please go ahead!
>
> Mathieu

Thanks, pushed as <https://git.savannah.gnu.org/cgit/guix.git/commit/?id=0f85081ed1d99be57d3544e0307e7fa9ca043be9>
diff mbox series

Patch

From aaaf4d84ce9c54ce079eb1cf44c7bcf44bc2bc8e Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Fri, 6 Jan 2023 01:01:55 -0500
Subject: [PATCH] gnu: picom: Update to 10.2.

* gnu/packages/compton.scm (picom): Update to 10.2.
[arguments]: Use a plain list and adjust accordingly.
[phases]{patch-autostart-files}: New phase.
---
 gnu/packages/compton.scm | 22 ++++++++++++++++++----
 1 file changed, 18 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/compton.scm b/gnu/packages/compton.scm
index 16feae4f2f..42af93aa31 100644
--- a/gnu/packages/compton.scm
+++ b/gnu/packages/compton.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2019 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
 ;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,6 +24,7 @@ 
 (define-module (gnu packages compton)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
+  #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system meson)
@@ -111,7 +113,7 @@  (define-public compton
 (define-public picom
   (package
     (name "picom")
-    (version "9.1")
+    (version "10.2")
     (source
      (origin
        (method git-fetch)
@@ -120,7 +122,7 @@  (define-public picom
              (commit (string-append "v" version))))
        (sha256
         (base32
-         "0q7j6kh9k7i201cwhnfc3bmp0hqrx7ngk3v4qsp8k0qfy1n3ma8n"))
+         "1vd4nhvfykwdhpyhb0jmcj333zxhm6dyikafd76fa4z4fhjrrs0b"))
        (file-name (string-append "picom-" version))))
     (build-system meson-build-system)
     (inputs
@@ -140,8 +142,20 @@  (define-public picom
     (native-inputs
      (list asciidoc pkg-config xorgproto))
     (arguments
-     `(#:build-type "release"
-       #:configure-flags '("-Dwith_docs=true")))
+     (list #:build-type "release"
+           #:configure-flags #~'("-Dwith_docs=true")
+           #:phases
+           #~(modify-phases %standard-phases
+               ;; This file would be patched by 'patch-dot-desktop-files but
+               ;; only in share/applications and not etc/xdg/autostart, so
+               ;; manually patch it before it is installed in either location.
+               ;; The 'patch-dot-desktop-files phase is still needed for other
+               ;; .desktop files.
+               (add-after 'unpack 'patch-autostart-files
+                 (lambda _
+                   (substitute* "picom.desktop"
+                     (("Exec=")
+                      (string-append "Exec=" #$output "/bin/"))))))))
     (home-page "https://github.com/yshui/picom")
     (synopsis "Compositor for X11, forked from Compton")
     (description
-- 
2.38.1