diff mbox series

bug#68613: [PATCH] gnu: Add python-scikit-opt.

Message ID 8734u0htsq.fsf@gnu.org
State New
Headers show
Series bug#68613: [PATCH] gnu: Add python-scikit-opt. | expand

Commit Message

Ludovic Courtès Feb. 10, 2024, 9:51 p.m. UTC
Hi,

TimotheeMathieu <timothee.mathieu@inria.fr> skribis:

> * gnu/packages/python-science.scm (python-scikit-opt): New variable.
>
> Change-Id: I47d6b35d9658a37a242b4db61d293fa7efd33802

In the meantime, qa.guix caught up and apparently all is fine.

Applied with the changes below, as per:

  https://guix.gnu.org/manual/devel/en/html_node/Synopses-and-Descriptions.html

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index c02c2b3f9b..2cdada5ef3 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -352,12 +352,12 @@  (define-public python-scikit-opt
     (build-system pyproject-build-system)
     (propagated-inputs (list python-numpy python-scipy))
     (home-page "https://github.com/guofei9987/scikit-opt")
-    (synopsis "Swarm Intelligence in Python")
+    (synopsis "Swarm intelligence algorithm in Python")
     (description
-     "Scikit-opt(or sko) is a Python module of Swarm Intelligence
-                  Algorithm.  Such as Genetic Algorithm, Particle Swarm Optimization,
-                  Simulated Annealing, Ant Colony Algorithm, Immune Algorithm,
-                  Artificial Fish Swarm Algorithm.")
+     "Scikit-opt (or sko) is a Python module implementing @dfn{swarm
+intelligence} algorithms: genetic algorithm, particle swarm optimization,
+simulated annealing, ant colony algorithm, immune algorithm, artificial fish
+swarm algorithm.")
     (license license:expat)))
 
 (define-public python-scikit-optimize