diff mbox series

[bug#69021] gnu: go-gotest-tools-assert: Add missing inputs.

Message ID 8734u0axjm.fsf@troyfigiel.com
State New
Headers show
Series [bug#69021] gnu: go-gotest-tools-assert: Add missing inputs. | expand

Commit Message

Troy Figiel Feb. 10, 2024, 6:34 p.m. UTC
* gnu/packages/golang.scm (go-gotest-tools-assert): Add missing inputs.
[native-inputs]: Move go-github-com-google-go-cmp-cmp and go-github-com-pkg-errors from here ...
[propagated-inputs]: ... to here. Add go-github-com-spf13-pflag and go-golang-org-x-tools.
---
 gnu/packages/golang.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)


base-commit: e257de4365b24a84f39813aea2e8b4ab6259f283

Comments

Sharlatan Hellseher Feb. 13, 2024, 9:43 p.m. UTC | #1
Hi,

Pushed as f8d1df5f985d9e38a9fd7ff3100cd52b997342a0 to master.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..8974118aec 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7535,10 +7535,11 @@  (define-public go-gotest-tools-assert
      `(#:tests? #f ; Test failure concerning message formatting (FIXME)
        #:import-path "gotest.tools/assert"
        #:unpack-path "gotest.tools"))
-    ;(propagated-inputs
-    ; `(("go-gotest-tools-internal-format" ,go-gotest-tools-internal-format)))
-    (native-inputs
-     (list go-github-com-pkg-errors go-github-com-google-go-cmp-cmp))
+    (propagated-inputs
+     (list go-github-com-google-go-cmp-cmp
+           go-github-com-pkg-errors
+           go-github-com-spf13-pflag
+           go-golang-org-x-tools))
     (synopsis "Compare values and fail a test when a comparison fails")
     (description "This package provides a way to compare values and fail a
 test when a comparison fails.")