diff mbox series

[bug#69045,v2] gnu: go-github-com-avast-retry-go: Remove examples.

Message ID 8734txcrwk.fsf@troyfigiel.com
State New
Headers show
Series [bug#69045,v2] gnu: go-github-com-avast-retry-go: Remove examples. | expand

Commit Message

Troy Figiel Feb. 11, 2024, 11:03 a.m. UTC
* gnu/packages/golang.scm (go-github-com-avast-retry-go): Remove examples.
[arguments]<#:phases>: Add remove-examples phase.
---
 gnu/packages/golang.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)


base-commit: 16d2be641424815a1779119bb64bc6ba1be1161b
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..7a89afb27a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1261,7 +1261,14 @@  (define-public go-github-com-avast-retry-go
          (sha256
           (base32 "0hb4b1668516a4gv8avmflr565b6c1h93phdb068hcjxxj8767ba"))))
       (build-system go-build-system)
-      (arguments `(#:import-path "github.com/avast/retry-go"))
+      (arguments
+       (list
+        #:import-path "github.com/avast/retry-go"
+        #:phases #~(modify-phases %standard-phases
+                     (add-after 'unpack 'remove-examples
+                       (lambda* (#:key import-path #:allow-other-keys)
+                         (delete-file-recursively
+                          (string-append "src/" import-path "/examples")))))))
       (propagated-inputs (list go-github-com-stretchr-testify))
       (home-page "https://github.com/avast/retry-go")
       (synopsis "Simple golang library for retry mechanism")