[bug#74329,06/10] gnu: Fix whitespace issues in Python package descriptions.

Message ID 8734hxrl5l.fsf@erlikon.ch
State New
Headers
Series None |

Commit Message

Gabriel Wicki Jan. 5, 2025, 9:22 p.m. UTC
  This mainly addresses `double-space after sentence end period' and `trailing
white space' issues.

* gnu/packages/astronomy.scm (python-tweakwcs): Fix description.
* gnu/packages/check.scm (python-pytest-subtesthack): Fix description.
* gnu/packages/python-xyz.scm (python-qnorm, python-uncertainties,
python-sre-yield): Fix description.
* gnu/packages/qt.scm (python-pyqt6-sip): Fix description.
---
 gnu/packages/astronomy.scm  |  2 +-
 gnu/packages/check.scm      | 10 +++++-----
 gnu/packages/python-xyz.scm |  6 +++---
 gnu/packages/qt.scm         |  5 +++--
 4 files changed, 12 insertions(+), 11 deletions(-)
  

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 815f39f461..f2225b71ee 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -6368,7 +6368,7 @@  (define-public python-tweakwcs
     (description
      "@code{tweakwcs} is a package that provides core algorithms for computing
 and applying corrections to @code{WCS} objects such as to minimize mismatch
-between image and reference catalogs. Currently only aligning images with
+between image and reference catalogs.  Currently only aligning images with
 @code{FITS WCS} and @code{JWST gWCS} are supported.")
     (license license:bsd-3)))
 
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 5fef10485b..b5c05e36c9 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2741,11 +2741,11 @@  (define-public python-pytest-subtesthack
     (propagated-inputs
      (list python-pytest))
     (synopsis "Set-up and tear-down fixtures for unit tests")
-    (description "This plugin allows you to set up and tear down fixtures within
-unit test functions that use @code{py.test}. This is useful for using
-@command{hypothesis} inside py.test, as @command{hypothesis} will call the test
-function multiple times, without setting up or tearing down fixture state as is
-normally the case.")
+    (description "This plugin allows you to set up and tear down fixtures
+within unit test functions that use @code{py.test}.  This is useful for using
+@command{hypothesis} inside py.test, as @command{hypothesis} will call the
+test function multiple times, without setting up or tearing down fixture state
+as is normally the case.")
     (home-page "https://github.com/untitaker/pytest-subtesthack/")
     (license license:unlicense)))
 
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2d6eff0892..f49794f3cd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14772,7 +14772,7 @@  (define-public python-qnorm
     (native-inputs (list python-setuptools python-wheel python-toml))
     (home-page "https://github.com/Maarten-vd-Sande/qnorm")
     (synopsis "Quantile normalization")
-    (description "This tool implements quantile normalization. It properly
+    (description "This tool implements quantile normalization.  It properly
 resolves rank ties, which is important when ties happen frequently, such as
 when working with discrete numbers (integers) in count tables.  This
 implementation should be relatively fast, and can use multiple cores to sort
@@ -19940,7 +19940,7 @@  (define-public python-uncertainties
     (synopsis "Calculations with uncertainties")
     (description
      "The uncertainties package transparently handles calculations with
-numbers with uncertainties. It can also yield the derivatives of any
+numbers with uncertainties.  It can also yield the derivatives of any
 expression.")
     (license license:bsd-3)))
 
@@ -37701,7 +37701,7 @@  (define-public python-sre-yield
     (synopsis "Expands a regular expression to its possible matches")
     (description
      "The goal of sre_yield is to efficiently generate all values that can
-match a given regular expression, or count possible matches efficiently. It
+match a given regular expression, or count possible matches efficiently.  It
 uses the parsed regular expression, so you get a much more accurate result
 than trying to just split strings.")
     (license license:asl2.0)))
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index e51962e0a7..be6cae57bb 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4248,8 +4248,9 @@  (define-public python-pyqt6-sip
         (base32 "1m39znwza9yypyd93i5mxd9pbf6zn9qdajczpm953awwdlywyx1g"))))
     (synopsis "Sip module support for PyQt6")
     (description
-     "SIP is used to write self contained extension modules, i.e. without a library
-to be wrapped. This SIP extension module provides support for the PyQt6 package.")))
+     "SIP is used to write self contained extension modules, i.e. without a
+library to be wrapped.  This SIP extension module provides support for the
+PyQt6 package.")))
 
 (define-public python-pyqtwebengine
   (package