[bug#74329,06/10] gnu: Fix whitespace issues in Python package descriptions.
Commit Message
This mainly addresses `double-space after sentence end period' and `trailing
white space' issues.
* gnu/packages/astronomy.scm (python-tweakwcs): Fix description.
* gnu/packages/check.scm (python-pytest-subtesthack): Fix description.
* gnu/packages/python-xyz.scm (python-qnorm, python-uncertainties,
python-sre-yield): Fix description.
* gnu/packages/qt.scm (python-pyqt6-sip): Fix description.
---
gnu/packages/astronomy.scm | 2 +-
gnu/packages/check.scm | 10 +++++-----
gnu/packages/python-xyz.scm | 6 +++---
gnu/packages/qt.scm | 5 +++--
4 files changed, 12 insertions(+), 11 deletions(-)
@@ -6368,7 +6368,7 @@ (define-public python-tweakwcs
(description
"@code{tweakwcs} is a package that provides core algorithms for computing
and applying corrections to @code{WCS} objects such as to minimize mismatch
-between image and reference catalogs. Currently only aligning images with
+between image and reference catalogs. Currently only aligning images with
@code{FITS WCS} and @code{JWST gWCS} are supported.")
(license license:bsd-3)))
@@ -2741,11 +2741,11 @@ (define-public python-pytest-subtesthack
(propagated-inputs
(list python-pytest))
(synopsis "Set-up and tear-down fixtures for unit tests")
- (description "This plugin allows you to set up and tear down fixtures within
-unit test functions that use @code{py.test}. This is useful for using
-@command{hypothesis} inside py.test, as @command{hypothesis} will call the test
-function multiple times, without setting up or tearing down fixture state as is
-normally the case.")
+ (description "This plugin allows you to set up and tear down fixtures
+within unit test functions that use @code{py.test}. This is useful for using
+@command{hypothesis} inside py.test, as @command{hypothesis} will call the
+test function multiple times, without setting up or tearing down fixture state
+as is normally the case.")
(home-page "https://github.com/untitaker/pytest-subtesthack/")
(license license:unlicense)))
@@ -14772,7 +14772,7 @@ (define-public python-qnorm
(native-inputs (list python-setuptools python-wheel python-toml))
(home-page "https://github.com/Maarten-vd-Sande/qnorm")
(synopsis "Quantile normalization")
- (description "This tool implements quantile normalization. It properly
+ (description "This tool implements quantile normalization. It properly
resolves rank ties, which is important when ties happen frequently, such as
when working with discrete numbers (integers) in count tables. This
implementation should be relatively fast, and can use multiple cores to sort
@@ -19940,7 +19940,7 @@ (define-public python-uncertainties
(synopsis "Calculations with uncertainties")
(description
"The uncertainties package transparently handles calculations with
-numbers with uncertainties. It can also yield the derivatives of any
+numbers with uncertainties. It can also yield the derivatives of any
expression.")
(license license:bsd-3)))
@@ -37701,7 +37701,7 @@ (define-public python-sre-yield
(synopsis "Expands a regular expression to its possible matches")
(description
"The goal of sre_yield is to efficiently generate all values that can
-match a given regular expression, or count possible matches efficiently. It
+match a given regular expression, or count possible matches efficiently. It
uses the parsed regular expression, so you get a much more accurate result
than trying to just split strings.")
(license license:asl2.0)))
@@ -4248,8 +4248,9 @@ (define-public python-pyqt6-sip
(base32 "1m39znwza9yypyd93i5mxd9pbf6zn9qdajczpm953awwdlywyx1g"))))
(synopsis "Sip module support for PyQt6")
(description
- "SIP is used to write self contained extension modules, i.e. without a library
-to be wrapped. This SIP extension module provides support for the PyQt6 package.")))
+ "SIP is used to write self contained extension modules, i.e. without a
+library to be wrapped. This SIP extension module provides support for the
+PyQt6 package.")))
(define-public python-pyqtwebengine
(package