[bug#35116,staging] Add python-robotframework et al.

Message ID 871s2j911q.fsf@gmail.com
State Accepted
Headers show
Series [bug#35116,staging] Add python-robotframework et al. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Maxim Cournoyer April 3, 2019, 4:15 a.m. UTC
Hello!

Here's a series adding a few new Python packages to support Robot
Framework, as well as the Emacs mode to accompany it.

python-pygithub will not build reproducibly until a fix is applied to
the Python build system (to be submitted in another change).

Thanks!

Maxim

Comments

Maxim Cournoyer April 20, 2019, 12:58 a.m. UTC | #1
I went ahead and pushed this series to staging (there was a requirement
on an updated python-requests that was present in staging but not in
master), after updating python-pygithub to its latest release and
adapting it a little bit so the tests could run successfully.

The commit at the top of the stack has the following hash: 73326e742d.

Closing.

Maxim

Patch

From 8c843de4a97752aba5563912236ce5e22ee3f9d1 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Mon, 1 Apr 2019 22:39:46 -0400
Subject: [PATCH 8/8] gnu: Add emacs-robot-mode.

* gnu/packages/emacs-xyz.scm (emacs-robot-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1e8d703ce3..aa1dad2a8e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2548,6 +2548,31 @@  definitions, modules and classes, display method documentation and provide
 method and constant name completion.")
     (license license:gpl3+)))
 
+(define-public emacs-robot-mode
+  (let ((commit "32846e7e80ae3471b7c07f9709dcaa4f9b9ed4a0")
+        (revision "1"))
+    (package
+      (name "emacs-robot-mode")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      ;; A better maintained fork of robot-mode.
+                      (url "https://github.com/jvalkeejarvi/robot-mode.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1i8wf7m0gml8zvvmlgppjzv78b432686p1qdbzgclc7qfcvzag0d"))))
+      (build-system emacs-build-system)
+      (propagated-inputs `(("emacs-s" ,emacs-s)))
+      (home-page "https://github.com/jvalkeejarvi/robot-mode")
+      (synopsis "Emacs mode for Robot Framework")
+      (description "This major mode facilitates editing Robot Framework source
+files with features such as syntax highlighting, comments, finding keywords,
+completing keywords and smart indentation.")
+      (license license:gpl3+))))
+
 (define-public emacs-rspec
   (package
     (name "emacs-rspec")
-- 
2.20.1