diff mbox series

[bug#40136] * gnu/packages/docker.scm (docker-compose): update to 1.25.4

Message ID 871rpoxjih.fsf@rohleder.de
State Accepted
Headers show
Series [bug#40136] * gnu/packages/docker.scm (docker-compose): update to 1.25.4 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder March 19, 2020, 6:54 p.m. UTC
Fixes <https://bugs.gnu.org/40015>

I tested this only briefly. I could build and run containers from
compose files, so its at least less broken than before where one couldnt
even start docker-compose.

This doesnt need the old jsonschema-2.6 and seems to work with our
current 3.0.1 version, so we can remove it (as stated in the comment).

Now, I am wondering if we need all the python-request versions...


* gnu/packages/docker.scm (docker-compose): update to 1.25.4
* gnu/packages/python-xyz.scm (python-jsonschema-2.6): remove variable.

Comments

Danny Milosavljevic March 19, 2020, 7:45 p.m. UTC | #1
Hi,

thanks for the patch!

Pushed to guix master as commit 15c3aa091100160bbe9c81650f9ab7a12bd7964e.
diff mbox series

Patch

From 69518dd1935db9ad58e43572688e8d72d645f501 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Thu, 19 Mar 2020 18:56:58 +0100
Subject: [PATCH] * gnu/packages/python-xyz.scm (python-jsonschema-2.6): remove
 variable.

---
 gnu/packages/python-xyz.scm | 26 --------------------------
 1 file changed, 26 deletions(-)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 07199aa7ca..8271e1ff7e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2306,32 +2306,6 @@  compare, diff, and patch JSON and JSON-like structures in Python.")
               `(("python2-functools32" ,python2-functools32)
                 ,@(package-propagated-inputs jsonschema))))))
 
-;; This old version is still required by docker-compose as of 1.24.0.
-(define-public python-jsonschema-2.6
-  (package
-    (name "python-jsonschema")
-    (version "2.6.0")
-    (source (origin
-             (method url-fetch)
-             (uri (pypi-uri "jsonschema" version))
-             (sha256
-              (base32
-               "00kf3zmpp9ya4sydffpifn0j0mzm342a2vzh82p6r0vh10cg7xbg"))))
-    (build-system python-build-system)
-    (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check (lambda _ (invoke "nosetests"))))))
-    (native-inputs
-     `(("python-nose" ,python-nose)
-       ("python-vcversioner" ,python-vcversioner)))
-    (home-page "https://github.com/Julian/jsonschema")
-    (synopsis "Implementation of JSON Schema for Python")
-    (description
-     "Jsonschema is an implementation of JSON Schema for Python.")
-    (license license:expat)
-    (properties `((python2-variant . ,(delay python2-jsonschema))))))
-
 (define-public python-schema
   (package
     (name "python-schema")
-- 
2.25.2