diff mbox series

bug#41580: [PATCH] gnu: Update python-pylint to 2.5.2

Message ID 871rn138qa.fsf@gnu.org
State Accepted
Headers show
Series bug#41580: [PATCH] gnu: Update python-pylint to 2.5.2 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Marius Bakke May 30, 2020, 12:31 p.m. UTC
Ryan Prior via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/check.scm (python-pylint): Updated version to 2.5.2

Thanks!  I fixed the commit message and applied with the following
changes:

Comments

Marius Bakke May 30, 2020, 9:34 p.m. UTC | #1
Marius Bakke <marius@gnu.org> writes:

> Ryan Prior via Guix-patches via <guix-patches@gnu.org> writes:
>
>> * gnu/packages/check.scm (python-pylint): Updated version to 2.5.2
>
> Thanks!  I fixed the commit message and applied with the following
> changes:

I had to revert this patch because it broke the Totem test suite:

  https://issues.guix.gnu.org/issue/41620

Can you take a look?

In the future, it's good if you run 'guix refresh -l package' and try to
build some of the important-looking dependents before submitting, GNOME
in this case.  :-)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index de4a978d97..8d99e67514 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1902,7 +1902,7 @@  statements in the module it tests.")
         (base32
          "150x679mrlgm1s4ym7irf9mnsjilqyaakss4spc4pbrzkl11agnh"))))
     (build-system python-build-system)
-    ;; Further releases, up to 2.4.3, have failing unit tests. See:
+    ;; FIXME: Tests are failing since version 2.4.3, see:
     ;; https://github.com/PyCQA/pylint/issues/3198.
     (arguments '(#:tests? #f))
     (native-inputs
@@ -1946,7 +1946,7 @@  possible to write plugins to add your own checks.")
                  (base32
                   "02a89d8a47s7nfiv1ady3j0sg2sbyja3np145brarfp5x9qxz9x2"))))
              (arguments
-              `(,@(package-arguments pylint)
+              `(,@(strip-keyword-arguments '(#:tests?) (package-arguments pylint))
                 #:phases
                 (modify-phases %standard-phases
                   (replace 'check