diff mbox series

[bug#42594] gnu: python-sqlparse: Update to 0.3.1.

Message ID 871rkuhi4b.fsf@rohleder.de
State Accepted
Headers show
Series [bug#42594] gnu: python-sqlparse: Update to 0.3.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Michael Rohleder July 29, 2020, 7:53 a.m. UTC
on trying to fix mycli:

tested this with building patchwork, postorius, mycli, python2-sqlparse
(which alltogether builds and tests a lot of other packages), so this
should ok.

(would also "fix" #41308)

Comments

Marius Bakke July 29, 2020, 10:52 p.m. UTC | #1
Michael Rohleder <mike@rohleder.de> writes:

> on trying to fix mycli:
>
> tested this with building patchwork, postorius, mycli, python2-sqlparse
> (which alltogether builds and tests a lot of other packages), so this
> should ok.

Awesome, thanks for checking dependent packages.

> (would also "fix" #41308)

Oh, good catch.

> * gnu/packages/databases.scm (python-sqlparse): Update to 0.3.1.

By the way, can you use 'git format-patch' to generate the attached
patches?  Currently I need to 'git am' the entire email and edit out the
text body from the commit message.

Another popular alternative is to use 'git send-email' directly to send
git-formatted patches directly, and add the text body after this line:

> ---
>  gnu/packages/databases.scm | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)

... i.e. here, to avoid it from becoming part of the commit message.

Anyway, applied!
diff mbox series

Patch

* gnu/packages/databases.scm (python-sqlparse): Update to 0.3.1.
---
 gnu/packages/databases.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index e5aab2c9e8..9ea567c002 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -43,6 +43,7 @@ 
 ;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
 ;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3106,13 +3107,13 @@  is designed to have a low barrier to entry.")
 (define-public python-sqlparse
   (package
     (name "python-sqlparse")
-    (version "0.2.4")
+    (version "0.3.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "sqlparse" version))
               (sha256
                (base32
-                "1v3xh0bkfhb262dbndgzhivpnhdwavdzz8jjhx9vx0xbrx2880nf"))))
+                "0j652a6z7bdf6c77aczfn8m8b2nsr1bcqq48wzghf8vi6wvj0qp1"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
-- 
2.27.0