diff mbox series

[bug#50648] gnu: Add tealdeer.

Message ID 871r5mx27l.fsf@asu.edu
State Accepted
Headers show
Series [bug#50648] gnu: Add tealdeer. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Soo Sept. 17, 2021, 10:32 p.m. UTC
Hi Guix,

I wanted to check out tealdeer and I didn't see it upstream. Here are my
patches for it, thanks!

- John

Comments

Efraim Flashner Sept. 22, 2021, 1:49 p.m. UTC | #1
On Fri, Sep 17, 2021 at 03:32:46PM -0700, John Soo wrote:
> Hi Guix,
> 
> I wanted to check out tealdeer and I didn't see it upstream. Here are my
> patches for it, thanks!
> 
> - John

I fixed the 'install-completions phase so that they would install in the
correct directories (as far as I knew) and with the correct names. I
also had it not install the sources.

Patches pushed! Thanks.
diff mbox series

Patch

From 6d8dd5ebcb448096ce43b68934c39066e38680fa Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Fri, 17 Sep 2021 12:37:56 -0700
Subject: [PATCH 3/3] gnu: Add tealdeer.

* gnu/packages/rust-apps.scm (tealdeer): New variable.
---
 gnu/packages/rust-apps.scm | 74 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 74 insertions(+)

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index e81c7d8748..800ba49fb9 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1051,6 +1051,80 @@  library and a dynamic library, and a C header to be used by any C (and
 C-compatible) software.")
     (license license:expat)))
 
+(define-public tealdeer
+  (package
+    (name "tealdeer")
+    (version "1.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "tealdeer" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0cwf46k2rszcpydrqajnm4dvhggr3ms7sjma0jx02ch4fjicxch7"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'install-completions
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out")))
+               (install-file
+                "bash_tealdeer"
+                (string-append out "/etc/bash_completion.d"))
+               (install-file
+                "fish_tealdeer"
+                (string-append
+                 out "/share/completions/vendor_completions.d"))))))
+       #:cargo-test-flags
+       '("--release" "--"
+         ;; These tests go to the network
+         "--skip=test_quiet_old_cache"
+         "--skip=test_quiet_cache"
+         "--skip=test_quiet_failures"
+         "--skip=test_pager_flag_enable"
+         "--skip=test_markdown_rendering"
+         "--skip=test_spaces_find_command"
+         "--skip=test_autoupdate_cache"
+         "--skip=test_update_cache")
+       #:cargo-inputs
+       (("rust-ansi-term" ,rust-ansi-term-0.12)
+        ("rust-app-dirs2" ,rust-app-dirs2-2)
+        ("rust-atty" ,rust-atty-0.2)
+        ("rust-docopt" ,rust-docopt-1)
+        ("rust-env-logger" ,rust-env-logger-0.7)
+        ("rust-flate2" ,rust-flate2-1)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-pager" ,rust-pager-0.15)
+        ("rust-reqwest" ,rust-reqwest-0.10)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-derive" ,rust-serde-derive-1)
+        ("rust-tar" ,rust-tar-0.4)
+        ("rust-toml" ,rust-toml-0.5)
+        ("rust-walkdir" ,rust-walkdir-2)
+        ("rust-xdg" ,rust-xdg-2))
+       #:cargo-development-inputs
+       (("rust-assert-cmd" ,rust-assert-cmd-1)
+        ("rust-escargot" ,rust-escargot-0.5)
+        ("rust-filetime" ,rust-filetime-0.2)
+        ("rust-predicates" ,rust-predicates-1)
+        ;; This earlier version is required to fix a bug.
+        ;; Remove rust-remove-dir-all-0.5.2 when tealdeer gets upgraded
+        ("rust-remove-dir-all" ,rust-remove-dir-all-0.5.2)
+        ("rust-tempfile" ,rust-tempfile-3))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("openssl" ,openssl)))
+    (home-page "https://github.com/dbrgn/tealdeer/")
+    (synopsis "Fetch and show tldr help pages for many CLI commands")
+    (description
+     "This package fetches and shows tldr help pages for many CLI commands.
+Full featured offline client with caching support.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public zoxide
   (package
     (name "zoxide")
-- 
2.33.0