diff mbox series

bug#52848: [PATCH] gnu: Add openshadinglanguage.

Message ID 871r183c2r.fsf@gnu.org
State Accepted
Headers show
Series bug#52848: [PATCH] gnu: Add openshadinglanguage. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès Jan. 15, 2022, 9:48 p.m. UTC
Hi Vinicius,

Vinicius Monego <monego@posteo.net> skribis:

> * gnu/packages/graphics.scm (openshadinglanguage): New variable.

Applied with the tweaks below.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index bc59652d33..b69ab52aec 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -604,21 +604,33 @@  (define-public openshadinglanguage
                        (string-append headers ":"
                                       (or (getenv "CPLUS_INCLUDE_PATH") ""))))))
          (replace 'check
-           (lambda _
-             (invoke "ctest" "--exclude-regex"
-                     (string-join
-                      (list
-                       "osl-imageio"      ; OIIO not compiled with freetype
-                       "osl-imageio.opt"  ; OIIO not compiled with freetype
-                       "texture-udim"     ; file does not exist
-                       "texture-udim.opt" ; file does not exist
-                       "example-deformer" ; could not find OSLConfig
-                       "python-oslquery") ; no module oslquery
-                      "|")))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "ctest" "--exclude-regex"
+                       (string-join
+                        (list
+                         "osl-imageio"       ; OIIO not compiled with freetype
+                         "osl-imageio.opt"   ; OIIO not compiled with freetype
+                         "texture-udim"      ; file does not exist
+                         "texture-udim.opt"  ; file does not exist
+                         "example-deformer"  ; could not find OSLConfig
+                         "python-oslquery")  ; no module oslquery
+                        "|"))))))))
     (native-inputs
-     (list bison clang flex llvm pybind11 python-wrapper))
+     (list bison
+           clang
+           flex
+           llvm
+           pybind11
+           python-wrapper))
     (inputs
-     (list boost imath openexr-2 openimageio pugixml qtbase-5 zlib))
+     (list boost
+           imath
+           openexr-2
+           openimageio
+           pugixml
+           qtbase-5
+           zlib))
     (home-page "https://github.com/AcademySoftwareFoundation/OpenShadingLanguage")
     (synopsis "Shading language for production GI renderers")
     (description "Open Shading Language (OSL) is a language for programmable