From b1b6cef5886852a987c926d31ff9c3aed8a0476a Mon Sep 17 00:00:00 2001
From: kitzman <kitzman@disroot.org>
Date: Wed, 23 Feb 2022 17:48:31 +0200
Subject: [PATCH 1/3] gnu: add libaml
---
gnu/packages/linux.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
@@ -8814,3 +8814,33 @@ (define-public libgpiod
(license (list license:lgpl2.1+ ;; libgpiod
license:gpl2+ ;; gpio-tools
license:lgpl3+)))) ;; C++ bindings
+
+(define-public libaml
+ (package
+ (name "libaml")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/any1/aml")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "aml" (string-append "v" version)))
+ (sha256
+ (base32
+ "0mxmzlhiv88hm4sf8kyawyrml8qy1xis019hdyb5skl9g95z9yyf"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list pkg-config))
+ (home-page "https://github.com/any1/aml")
+ (synopsis "Another/Andri's main loop")
+ (description "The @code{aml} library provides an event loop for C, for Linux,
+with the following features:
+@enumerate
+@item fd event handlers
+@item timers and tickers
+@item signal handlers
+@item idle dispatch callbacks
+@item thread pool support
+@end enumerate
+")
+ (license license:isc)))
--
2.32.0