diff mbox series

[bug#54078,1/3] gnu: add libaml

Message ID 871qztqxpt.fsf_-_@disroot.org
State New
Headers show
Series [bug#54078,1/3] gnu: add libaml | expand

Commit Message

kitzman Feb. 23, 2022, 5:50 p.m. UTC
Dear Maxime,

Thank you for reviewing.
I have attached here the fixed patch for libaml. The rest of the patches
are going to be part of the new series.

Kind regards,
Kitzman

Comments

M Feb. 23, 2022, 5:58 p.m. UTC | #1
kitzman schreef op wo 23-02-2022 om 19:50 [+0200]:
> +    (description "The @code{aml} library provides an event loop for
> C, for Linux,

According to the README, it has portability as a goal.
Looking at src/kqueue.c, it supports some BSDs.
Looking at posix.c, it should support anything POSIX-like
(and hence, the Hurd).

As such, I don't think the qualifier 'for Linux' is very meaningful
here.

> +with the following features:
> +@enumerate
> +@item fd event handlers

‘(guix)Synopses and Descriptions’ recommends avoiding acronyms:

[...] Use full sentences, and avoid using acronyms without first
introducing them. [...]

‘@item file descriptor event handlers’ would be more explicit and
avoids the 'fd' acronym.

Otherwise, the description looks nice to me.

Greetings,
Maxime.
diff mbox series

Patch

From b1b6cef5886852a987c926d31ff9c3aed8a0476a Mon Sep 17 00:00:00 2001
From: kitzman <kitzman@disroot.org>
Date: Wed, 23 Feb 2022 17:48:31 +0200
Subject: [PATCH 1/3] gnu: add libaml

---
 gnu/packages/linux.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1c514c3cec..9cc619f9de 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8814,3 +8814,33 @@  (define-public libgpiod
     (license (list license:lgpl2.1+   ;; libgpiod
                    license:gpl2+      ;; gpio-tools
                    license:lgpl3+)))) ;; C++ bindings
+
+(define-public libaml
+  (package
+    (name "libaml")
+    (version "0.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/any1/aml")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name "aml" (string-append "v" version)))
+              (sha256
+               (base32
+                "0mxmzlhiv88hm4sf8kyawyrml8qy1xis019hdyb5skl9g95z9yyf"))))
+    (build-system meson-build-system)
+    (native-inputs
+     (list pkg-config))
+    (home-page "https://github.com/any1/aml")
+    (synopsis "Another/Andri's main loop")
+    (description "The @code{aml} library provides an event loop for C, for Linux,
+with the following features:
+@enumerate
+@item fd event handlers
+@item timers and tickers
+@item signal handlers
+@item idle dispatch callbacks
+@item thread pool support
+@end enumerate
+")
+    (license license:isc)))
-- 
2.32.0