diff mbox series

[bug#54201] Add wego

Message ID 871qzmwm4w.fsf@nicolasgoaziou.fr
State Accepted
Headers show
Series [bug#54201] Add wego | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Goaziou March 1, 2022, 12:29 a.m. UTC
Hello,

The following two patches add wego. I create a new "weather.scm" file
since I didn't know where to put it.

Regards,

Comments

Ludovic Courtès March 18, 2022, 1:59 p.m. UTC | #1
Hi,

Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:

>>From 84b5ea4501014800ec43b6335af6b554716f8ce0 Mon Sep 17 00:00:00 2001
> Message-Id: <84b5ea4501014800ec43b6335af6b554716f8ce0.1646094084.git.mail@nicolasgoaziou.fr>
> In-Reply-To: <b8ff68982388247600aa8f4771e6ccd5794acf0e.1646094084.git.mail@nicolasgoaziou.fr>
> References: <b8ff68982388247600aa8f4771e6ccd5794acf0e.1646094084.git.mail@nicolasgoaziou.fr>
> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
> Date: Tue, 1 Mar 2022 01:14:04 +0100
> Subject: [[PATCH] 2/2] gnu: Add wego.
>
> * gnu/packages/weather.scm: New file.
> * gnu/local.mk: Register new file.

[...]

> +++ b/gnu/packages/weather.scm
> @@ -0,0 +1,34 @@
> +(define-module (gnu packages weather)

Please add a license header.


[...]

> +    (home-page "https://github.com/schachmat/wego")
> +    (synopsis "Weather client for the terminal")
> +    (description "@strong{wego} is a weather client for the terminal.")

Could you expound a little bit, mentioning key features, etc.?

You can prolly remove @strong.

> +    (license isc)))

Perhaps #:prefix license: ?

Otherwise LGTM, thanks!

Ludo’.
Nicolas Goaziou March 18, 2022, 11:59 p.m. UTC | #2
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

> Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:

>> +++ b/gnu/packages/weather.scm
>> @@ -0,0 +1,34 @@
>> +(define-module (gnu packages weather)
>
> Please add a license header.

Done.

>> +    (description "@strong{wego} is a weather client for the terminal.")
>
> Could you expound a little bit, mentioning key features, etc.?
>
> You can prolly remove @strong.

Done.

>> +    (license isc)))
>
> Perhaps #:prefix license: ?

I thought we needed to use the prefix only when there was a conflict in
the module.

Anyhow, done.

> Otherwise LGTM, thanks!

Applied. Thank you.

Regards,
diff mbox series

Patch

From 84b5ea4501014800ec43b6335af6b554716f8ce0 Mon Sep 17 00:00:00 2001
Message-Id: <84b5ea4501014800ec43b6335af6b554716f8ce0.1646094084.git.mail@nicolasgoaziou.fr>
In-Reply-To: <b8ff68982388247600aa8f4771e6ccd5794acf0e.1646094084.git.mail@nicolasgoaziou.fr>
References: <b8ff68982388247600aa8f4771e6ccd5794acf0e.1646094084.git.mail@nicolasgoaziou.fr>
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Tue, 1 Mar 2022 01:14:04 +0100
Subject: [[PATCH] 2/2] gnu: Add wego.

* gnu/packages/weather.scm: New file.
* gnu/local.mk: Register new file.
---
 gnu/local.mk             |  1 +
 gnu/packages/weather.scm | 34 ++++++++++++++++++++++++++++++++++
 2 files changed, 35 insertions(+)
 create mode 100644 gnu/packages/weather.scm

diff --git a/gnu/local.mk b/gnu/local.mk
index bc214b3443..4915ccbe2b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -603,6 +603,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/vulkan.scm			\
   %D%/packages/w3m.scm				\
   %D%/packages/wdiff.scm			\
+  %D%/packages/weather.scm			\
   %D%/packages/web.scm				\
   %D%/packages/web-browsers.scm			\
   %D%/packages/webkit.scm			\
diff --git a/gnu/packages/weather.scm b/gnu/packages/weather.scm
new file mode 100644
index 0000000000..bd83c1b660
--- /dev/null
+++ b/gnu/packages/weather.scm
@@ -0,0 +1,34 @@ 
+(define-module (gnu packages weather)
+  #:use-module (guix build-system go)
+  #:use-module (guix git-download)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages golang))
+
+(define-public wego
+  (package
+    (name "wego")
+    (version "2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/schachmat/wego")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0bji9fywa0kg29zj1vrwq7l5f18hh0lcz6rl6sppi5id0qbjpiwl"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/schachmat/wego"))
+    (propagated-inputs
+     (list go-golang-org-x-sys
+           go-github-com-rivo-uniseg
+           go-github-com-mattn-go-isatty
+           go-github-com-schachmat-ingo
+           go-github-com-mattn-go-runewidth
+           go-github-com-mattn-go-colorable))
+    (home-page "https://github.com/schachmat/wego")
+    (synopsis "Weather client for the terminal")
+    (description "@strong{wego} is a weather client for the terminal.")
+    (license isc)))
-- 
2.34.0