diff mbox series

[bug#55547] gnu: gandi.cli: Fix build.

Message ID 871qwoarr0.fsf@gmx.com
State Accepted
Headers show
Series [bug#55547] gnu: gandi.cli: Fix build. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pierre Langlois May 20, 2022, 8:06 p.m. UTC
Hi Guix!

I just realized the gandi.cli program doens't build, it appear to
require version 7 of python-click. Here are a couple of patches to fix
it.

The patches are pretty trivial, I guess I should be able to just push
them? I'm never too sure :-).

Thanks,
Pierre

Comments

Ludovic Courtès May 30, 2022, 2:28 p.m. UTC | #1
Hi,

Pierre Langlois <pierre.langlois@gmx.com> skribis:

> The patches are pretty trivial, I guess I should be able to just push
> them? I'm never too sure :-).

Yes please, go ahead!

For the record, the rules are given here:

  https://guix.gnu.org/manual/devel/en/html_node/Commit-Access.html#Commit-Policy

To me these patches fall under the “trivial patch” rule (and also under
the “two week” rule actually!).

Thanks,
Ludo’.
Pierre Langlois May 30, 2022, 9:19 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Hi,
>
> Pierre Langlois <pierre.langlois@gmx.com> skribis:
>
>> The patches are pretty trivial, I guess I should be able to just push
>> them? I'm never too sure :-).
>
> Yes please, go ahead!

Pushed with b8fc3403d3c09c00a4b0ab68c9f4f296928479b9.

>
> For the record, the rules are given here:
>
>   https://guix.gnu.org/manual/devel/en/html_node/Commit-Access.html#Commit-Policy
>
> To me these patches fall under the “trivial patch” rule (and also under
> the “two week” rule actually!).

Ah thanks for clarifying! I wasn't aware of the "two week" rule.

Pierre
diff mbox series

Patch

From 7fe4df8b6595d491ab6fbb7c41b207f0a611423f Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Tue, 17 May 2022 20:46:53 +0100
Subject: [PATCH 2/2] gnu: gandi.cli: Fix by downgrading python-click.

* gnu/packages/python-xyz.scm (python-click-7): New variable.
* gnu/packages/networking.scm (gandi.cli)[inputs]: Depend on python-click-7.
---
 gnu/packages/networking.scm |  3 ++-
 gnu/packages/python-xyz.scm | 12 ++++++++++++
 2 files changed, 14 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 9010e1f120..c9a6dd1706 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -48,6 +48,7 @@ 
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2022 Simon South <simon@simonsouth.net>
+;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1654,7 +1655,7 @@  (define-public gandi.cli
     (propagated-inputs
      (list openssh))           ; used by gandi/cli/modules/iass.py
     (inputs
-     (list openssl python-click python-ipy python-pyyaml python-requests))
+     (list openssl python-click-7 python-ipy python-pyyaml python-requests))
     (home-page "https://cli.gandi.net")
     (synopsis "Command-line interface to the Gandi.net Web API")
     (description
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b64757f21e..44056f8d44 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3643,6 +3643,18 @@  (define-public python-click
 with sensible defaults out of the box.")
     (license license:bsd-3)))
 
+(define-public python-click-7
+  (package (inherit python-click)
+    (name "python-click")
+    (version "7.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "click" version))
+       (sha256
+        (base32 "06kbzd6sjfkqan3miwj9wqyddfxc2b6hi7p5s4dvqjb3gif2bdfj"))))
+    (arguments `())))
+
 (define-public python-click-5
   (package (inherit python-click)
     (name "python-click")
-- 
2.36.1