diff mbox series

[bug#57365] gnu: guile-smc: Update to 0.5.0

Message ID 871qsuwb4y.fsf@gmail.com
State Accepted
Headers show
Series [bug#57365] gnu: guile-smc: Update to 0.5.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov Sept. 2, 2022, 6:20 a.m. UTC
Hello,

I released Guile-SMC 0.5.2:
  https://lists.gnu.org/archive/html/guile-user/2022-09/msg00002.html

And Guile-INI 0.5.1:
  https://lists.gnu.org/archive/html/guile-user/2022-09/msg00003.html

So I updated both Guile-SMC and Guile-INI package definitions
accordingly.

Not sure if I should create a new thread in the mailing list for this.

For now please find updated patches attached below.
Thanks,

- Artyom

Comments

Mathieu Othacehe Sept. 2, 2022, 7:38 a.m. UTC | #1
Hey Artyom,

> Not sure if I should create a new thread in the mailing list for this.
>
> For now please find updated patches attached below.

It's great that you found a way to deal with logging. Guile-SMC looks
fun, can't wait to test it :).

Pushed both patches.

Thanks,

Mathieu
diff mbox series

Patch

From a9eff226c36bf0a8a1356da17f5ca1434fa9d593 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Tue, 23 Aug 2022 21:41:47 +0300
Subject: [PATCH 2/2] gnu: guile-ini: Update to 0.5.1.

* gnu/packages/guile-xyz.scm (guile-ini): Update to 0.5.1.
---
 gnu/packages/guile-xyz.scm | 45 +++++++++++++++++++++-----------------
 1 file changed, 25 insertions(+), 20 deletions(-)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 11fa92d08a..7df3012568 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4931,28 +4931,33 @@  (define-public guile-smc
 (define-public guile-ini
   (package
     (name "guile-ini")
-    (version "0.3.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/artyom-poptsov/guile-ini")
-             (commit (string-append "v" version))))
-       (file-name (string-append name "-" version))
-       (sha256
-        (base32
-         "0injn60530valhx3gsmdp72g6z886yf0n08hscky21h3dafm14kc"))))
+    (version "0.5.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/artyom-poptsov/guile-ini")
+                    (commit (string-append "v" version))))
+              (file-name (string-append name "-" version))
+              (sha256
+               (base32
+                "0ky7sffxywc2p84q5kdsphr99q0g5gy45rj0vx7f77hwpfm2093x"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags '("GUILE_AUTO_COMPILE=0")))     ;to prevent guild warnings
-    (native-inputs
-     (list autoconf automake pkg-config texinfo))
-    (inputs
-     `(("bash" ,bash-minimal)
-       ("guile" ,guile-3.0)
-       ("guile-lib" ,guile-lib)))
-    (propagated-inputs
-     (list guile-smc))
+     `(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
+       #:phases (modify-phases %standard-phases
+                  (delete 'strip)
+                  (add-before 'build 'generate-fsm-context
+                    ;; Make sure the intermediate FSM context is present
+                    ;; before the build.
+                    (lambda _
+                      (let ((cwd (getcwd)))
+                        (chdir "modules/ini/")
+                        (invoke "make" "GUILE_AUTO_COMPILE=0"
+                                "fsm-context.scm")
+                        (chdir cwd)))))))
+    (native-inputs (list autoconf automake pkg-config texinfo))
+    (inputs (list bash-minimal guile-3.0 guile-lib))
+    (propagated-inputs (list guile-smc))
     (home-page "https://github.com/artyom-poptsov/guile-ini")
     (synopsis "Guile library for INI format support")
     (description
-- 
2.34.1