diff mbox series

[bug#67251] gnu: python-imbalanced-learn: Update to 0.11.0.

Message ID 871qcolyr8.fsf@troyfigiel.com
State New
Headers show
Series [bug#67251] gnu: python-imbalanced-learn: Update to 0.11.0. | expand

Commit Message

Troy Figiel Nov. 17, 2023, 11:56 p.m. UTC
* gnu/packages/machine-learning.scm (python-imbalanced-learn): Update to
0.11.0.
[arguments]
<#:test-flags>: Move broken tests from "unbreak-tests" phase
to here.
<#:phases>: Add back some deleted python-keras and tensorflow tests.
[native-inputs]: Add python-keras, python-numpydoc and tensorflow.

Change-Id: Ibc2827e27ee23e0ffb491cb791bba4d1a3f1109d
---
 gnu/packages/machine-learning.scm | 65 +++++++++++++++----------------
 1 file changed, 31 insertions(+), 34 deletions(-)

Comments

Arun Isaac Nov. 20, 2023, 7 p.m. UTC | #1
Pushed, thanks!

I split the `guix style' reformatting into a separate commit.
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index a84377e1eb..7d833005bc 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1663,45 +1663,42 @@  (define-public python-tslearn
 (define-public python-imbalanced-learn
   (package
     (name "python-imbalanced-learn")
-    (version "0.9.1")
-    (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "imbalanced-learn" version))
-              (sha256
-               (base32
-                "0qnrmysnqpc8ii1w5n8mci20gcjhmjr7khvk7f2apdbqc2pgf52f"))))
+    (version "0.11.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "imbalanced-learn" version))
+       (sha256
+        (base32 "1p4gdgc8nsq0vjmw4y4d2bp9g0m1c23d0zgrzs90pnz6b24ax0km"))))
     (build-system pyproject-build-system)
     (arguments
      (list
-      #:phases
-      '(modify-phases %standard-phases
-         (add-after 'unpack 'unbreak-tests
-           (lambda _
-             ;; The doctests require tensorflow
-             (substitute* "setup.cfg"
-               (("--doctest-modules") ""))
-             ;; Some tests require a home directory
-             (setenv "HOME" (getcwd))
-             ;; We don't have keras
-             (delete-file "imblearn/keras/tests/test_generator.py")
-             ;; We don't have tensorflow
-             (delete-file "imblearn/tensorflow/tests/test_generator.py"))))))
-    (propagated-inputs
-     (list python-joblib
-           python-numpy
-           python-scikit-learn
-           python-scipy
-           python-threadpoolctl))
-    (native-inputs
-     (list python-black
-           python-flake8
-           python-mypy
-           python-pandas
-           python-pytest
-           python-pytest-cov))
+      #:test-flags '(list "-k"
+                     ;; Although we cannot satify the Tensorflow and Keras requirements
+                     ;; (python-keras >= 2.4.3 and tensorflow >= 2.4.3), all tests
+                     ;; besides these pass.
+                     "not balanced_batch_generator and not BalancedBatchGenerator")
+      #:phases '(modify-phases %standard-phases
+                  (add-after 'unpack 'unbreak-tests
+                    (lambda _
+                      ;; Some tests require a home directory
+                      (setenv "HOME"
+                              (getcwd)))))))
+    (propagated-inputs (list python-joblib python-numpy python-scikit-learn
+                             python-scipy python-threadpoolctl))
+    (native-inputs (list python-black
+                         python-flake8
+                         python-keras
+                         python-mypy
+                         python-numpydoc
+                         python-pandas
+                         python-pytest
+                         python-pytest-cov
+                         tensorflow))
     (home-page "https://github.com/scikit-learn-contrib/imbalanced-learn")
     (synopsis "Toolbox for imbalanced dataset in machine learning")
-    (description "This is a Python package offering a number of re-sampling
+    (description
+     "This is a Python package offering a number of re-sampling
 techniques commonly used in datasets showing strong between-class imbalance.
 It is compatible with @code{scikit-learn}.")
     (license license:expat)))