diff mbox series

[bug#68133] gnu: mesa: Fix cross-compiling again.

Message ID 871qape5qz.fsf@iscas.ac.cn
State New
Headers show
Series [bug#68133] gnu: mesa: Fix cross-compiling again. | expand

Commit Message

Zheng Junjie Jan. 10, 2024, 12:19 p.m. UTC
Mathieu Othacehe <othacehe@gnu.org> writes:

> Hello,
>
>> * gnu/packages/gl.scm(mesa)[native-inputs]: when cross-compile, add
>> cmake-minimal-cross.
>> [arguments]: adjust fix-cross-compiling to find llvm.
>>
>> * gnu/packages/llvm.scm(llvm-for-mesa)
>> [arguments]<#:configure-flags>: When cross-compile, set
>> -DBUILD_SHARED_LIBS:BOOL=TRUE and -DCMAKE_BUILD_WITH_INSTALL_RPATH=TRUE,
>> remove -DLLVM_LINK_LLVM_DYLIB.* .
>> <#:phases>: when cross-compile, remove delete-static-libraries phase.
>
> I amended the commit message and applied,
>
> Thanks,
>
> Mathieu

after mesa-updates merge, mesa's meson.build use config-tool method to
find llvm, so cross compile break again, this patch fix it.

``` meson.build
1712|    method : host_machine.system() == 'windows' ? 'auto' : 'config-tool',
```

Comments

Mathieu Othacehe Jan. 10, 2024, 2:30 p.m. UTC | #1
Hello,

> after mesa-updates merge, mesa's meson.build use config-tool method to
> find llvm, so cross compile break again, this patch fix it.
>
> ``` meson.build
> 1712|    method : host_machine.system() == 'windows' ? 'auto' : 'config-tool',
> ```

Applied with an amended commit message,

Thanks,

Mathieu
diff mbox series

Patch

From c7b0f3a8f4886da8a3b120758409abf3777a82f8 Mon Sep 17 00:00:00 2001
Message-ID: <c7b0f3a8f4886da8a3b120758409abf3777a82f8.1704889051.git.zhengjunjie@iscas.ac.cn>
From: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Date: Wed, 10 Jan 2024 20:14:32 +0800
Subject: [PATCH] gnu: mesa: fix cross-compiling again.

* gnu/packages/gl.scm(mesa)[arguments]<#:phases>: when cross compiling, force
use cmake method to find llvm.

Change-Id: I27f6f4d9d71028c15588eeade48d3a918c042b9c
---
 gnu/packages/gl.scm | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 7998142b4d..49dc878c02 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -421,6 +421,9 @@  (define-public mesa
                      ;; When cross compiling, we use cmake to find llvm, not
                      ;; llvm-config, because llvm-config cannot be executed
                      ;; see https://github.com/llvm/llvm-project/issues/58984
+                     (substitute* "meson.build"
+                       (("method : host_machine\\.system.*")
+                        "method : 'cmake',\n"))
                      (setenv "CMAKE"
                              (search-input-file
                               native-inputs "/bin/cmake")))))

base-commit: e541f9593f8bfc84b6140c2408b393243289fae6
-- 
2.41.0