diff mbox series

[bug#68425] gnu: python-activepapers: Fix build.

Message ID 871qal4cl5.fsf@troyfigiel.com
State New
Headers show
Series [bug#68425] gnu: python-activepapers: Fix build. | expand

Commit Message

Troy Figiel Jan. 13, 2024, 12:23 p.m. UTC
* gnu/packages/python-xyz.scm (python-activepapers)[source]: Add snippet fixing MutableMapping import.
---
 gnu/packages/python-xyz.scm | 6 ++++++
 1 file changed, 6 insertions(+)


base-commit: c0b303aaa3d6154acbe054120d11467eb98e6d33

Comments

Troy Figiel Jan. 13, 2024, 1:05 p.m. UTC | #1
python-activepapers has not been maintained since 2017. This patch is a
quick fix, but the latest version is actually built for Python >=3.3,
<=3.5. Trying to keep it buildable against newer versions of Python
would increase the maintenance burden over time.

Would it make more sense to remove/deprecate this package altogether?
Sharlatan Hellseher Jan. 14, 2024, 11:25 p.m. UTC | #2
Hi,

Pinging Konrad to check the status of the project as
 he was the last commiter to upstream package.

Thanks,
Oleg

-- 
VCS: https://github.incerto.xyz/; https://git.sr.ht/~hellseher/
GPG: 9847 81DE 689C 21C2 6418 0867 76D7 27BF F62C D2B5

… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Konrad Hinsen Jan. 15, 2024, 8:57 a.m. UTC | #3
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> Pinging Konrad to check the status of the project as
>  he was the last commiter to upstream package.

Thanks for the ping!

It's OK to deprecate or remove this package, since it is useful only
with time-machine going back a few years.

I just added a note to the README:

   https://github.com/activepapers/activepapers-python/blob/master/README.md

and archived the project.

Cheers,
  Konrad.
Sharlatan Hellseher Jan. 15, 2024, 9:09 p.m. UTC | #4
Hi,

I've remvoed the package.
Pushed as  1e3f1f9f92c1d3727d1ef69aa11455286abd0ebc.

Thanks,
Oleg
-- 
VCS: https://github.incerto.xyz/; https://git.sr.ht/~hellseher/
GPG: 9847 81DE 689C 21C2 6418 0867 76D7 27BF F62C D2B5

… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 37d7dd0dd5..ddba925fd7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24143,6 +24143,12 @@  (define-public python-activepapers
      (origin
        (method url-fetch)
        (uri (pypi-uri "ActivePapers.Py" version))
+       ;; This package has not seen active maintenance since 2017. This is a
+       ;; hack needed to make it build against a recent version of Python 3.
+       (modules '((guix build utils)))
+       (snippet '(substitute* "lib/activepapers/execution.py"
+                   (("collections\\.MutableMapping")
+                    "collections.abc.MutableMapping")))
        (sha256
         (base32
          "12wkhjh90ffipjzv10swndp2xv9hd7xrxvg6v0n4n3i411pj4xb8"))))