diff mbox series

[bug#68903] fix builds on !x86_64 and update to 1.0.34

Message ID 871q9u8e03.fsf@wireframe
State New
Headers show
Series [bug#68903] fix builds on !x86_64 and update to 1.0.34 | expand

Commit Message

Vagrant Cascadian Feb. 3, 2024, 2:42 a.m. UTC
The attached patch updates wabt to 1.0.34 and also disables tests on
non-x86_64 architectures.

Since the update to wabt 1.0.32 in commit
9d474e105977e46d1ffd9afe794d26882a66c7a0, tests were also enabled... but
it has failed to build architectures other than x86_64 ever since...

Because of this, diffoscope and reprotest have not been able to build,
as diffoscope has wabt in native-inputs.

Thanks to ulfvonbelow via #guix IRC for the simple suggestion of how to
disable tests!

Another option would be to selectively disable tests, though
historically there have been a number of relevent outstanding issues
related to tests on !x86_64, which might turn into a few rounds of
whack-a-mole every time wabt is updated:

  https://github.com/WebAssembly/wabt/issues/1045
  https://github.com/WebAssembly/wabt/issues/1044
  https://github.com/WebAssembly/wabt/issues/2118
  https://github.com/WebAssembly/wabt/issues/2240


live well,
  vagrant

Comments

Vagrant Cascadian Feb. 9, 2024, 9:47 p.m. UTC | #1
On 2024-02-02, Vagrant Cascadian wrote:
> The attached patch updates wabt to 1.0.34 and also disables tests on
> non-x86_64 architectures.
>
> Since the update to wabt 1.0.32 in commit
> 9d474e105977e46d1ffd9afe794d26882a66c7a0, tests were also enabled... but
> it has failed to build architectures other than x86_64 ever since...
>
> Because of this, diffoscope and reprotest have not been able to build,
> as diffoscope has wabt in native-inputs.

Pushed to master as 8ffc9233681863408034c8e371c5cfd3591545d2.

Looking forward to diffoscope on non-x86_64 again!

live well,
  vagrant
diff mbox series

Patch

From a378a8b7b23c2be9f8374d28fc1f89134a9fd272 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Fri, 2 Feb 2024 15:32:04 -0800
Subject: [PATCH] gnu: wabt: Update to 1.0.34.

* gnu/packages/web.scm (wabt): Update to 1.0.34.
[arguments]: Disable tests on !x86_64.
---
 gnu/packages/web.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 1a97dd8dec..1eefb1fde7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1638,7 +1638,7 @@  (define-public libwebsockets
 (define-public wabt
   (package
     (name "wabt")
-    (version "1.0.32")
+    (version "1.0.34")
     (source
      (origin
        (method git-fetch)
@@ -1648,13 +1648,15 @@  (define-public wabt
              (recursive? #true)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0m124r8v9c0hxiaa4iy7ch4ng8msnirbc2vb702gbdjhvgzyrcwh"))
+        (base32 "1vxvc34b7a7lkrmzdb5cjv0b54vhiyr33sy0i2ps5jrmg5rqqmia"))
        (modules '((guix build utils)))
        (snippet
         '(delete-file-recursively "third_party/gtest/"))))
     (build-system cmake-build-system)
     (arguments
      (list
+      ;; Tests on non-x86_64 architectures are not well supported upstream.
+      #:tests? (target-x86-64?)
       #:test-target "run-tests"
       #:configure-flags '(list "-DUSE_SYSTEM_GTEST=ON")
       #:phases

base-commit: f45d05133472a9da13eae20ba4a676c696682c90
-- 
2.39.2