diff mbox series

[bug#69046,v2] gnu: go-github-com-goccy-yaml: Remove benchmarks.

Message ID 871q9hcrh4.fsf@troyfigiel.com
State New
Headers show
Series [bug#69046,v2] gnu: go-github-com-goccy-yaml: Remove benchmarks. | expand

Commit Message

Troy Figiel Feb. 11, 2024, 10:44 a.m. UTC
* gnu/packages/golang.scm (go-github-com-goccy-yaml): Remove benchmarks.
[arguments]<#:phases>: Add remove-benchmarks phase.
---
 gnu/packages/golang.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)


base-commit: 16d2be641424815a1779119bb64bc6ba1be1161b
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..42450fbc4b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9629,7 +9629,13 @@  (define-public go-github-com-goccy-yaml
         (base32 "1nps58dwkd915mx35h5f0dc05b880b4fdl6dcjxpfmmbzyinvg38"))))
     (build-system go-build-system)
     (arguments
-     `(#:import-path "github.com/goccy/go-yaml"))
+     (list
+      #:import-path "github.com/goccy/go-yaml"
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'remove-benchmarks
+                     (lambda* (#:key import-path #:allow-other-keys)
+                       (delete-file-recursively
+                        (string-append "src/" import-path "/benchmarks")))))))
     (propagated-inputs
      (list go-github-com-fatih-color go-golang-org-x-xerrors))
     (native-inputs