diff mbox series

bug#73459: [PATCH] gnu: qview: Update to 6.1.

Message ID 871q0431w7.fsf@gnu.org
State New
Headers show
Series bug#73459: [PATCH] gnu: qview: Update to 6.1. | expand

Commit Message

Ludovic Courtès Oct. 25, 2024, 10:36 a.m. UTC
Sergey Trofimov <sarg@sarg.org.ru> skribis:

> * gnu/packages/image-viewers.scm (qview): Update to 6.1.
> [inputs, native-inputs]: Use qt6.
> [arguments]: Disable broken tests. Workaround lrelease being resolved
> relative to qtbase instead of qttools.

Hi! Applied it with the change below, which resorts to a literal
regexp in ‘substitute*’, which is usually safer:

--8<---------------cut here---------------start------------->8---
--8<---------------cut here---------------end--------------->8---

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 7fd8585ff1..cb4e903f39 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -721,7 +721,7 @@  (define-public qview
             (lambda* (#:key inputs outputs #:allow-other-keys)
               (invoke "qmake" (string-append "PREFIX=" #$output))
               (substitute* "Makefile"
-                (((string-append #$qtbase "/bin/lrelease"))
+                (("[[:graph:]]+/bin/lrelease")
                  (search-input-file inputs "/bin/lrelease")))))
           ;; Don't phone home or show "Checking for updates..." in the About
           ;; menu.