diff mbox series

[bug#43085] gnu: Add hdt-cpp.

Message ID 86zh6ff4sw.fsf@posteo.net
State Accepted
Headers show
Series [bug#43085] gnu: Add hdt-cpp. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

pukkamustard Aug. 28, 2020, 10:22 a.m. UTC
Hi Guix,

Tested by installing and running the command-line tools as well as 
using
C++ library with the example programs.

-pukkamustard

Comments

Leo Famulari Aug. 28, 2020, 11:27 p.m. UTC | #1
On Fri, Aug 28, 2020 at 12:22:39PM +0200, pukkamustard wrote:
> Tested by installing and running the command-line tools as well as using
> C++ library with the example programs.

> From e1033cab6f57503fdc5d08637058ca74e039a429 Mon Sep 17 00:00:00 2001
> From: pukkamustard <pukkamustard@posteo.net>
> Date: Fri, 28 Aug 2020 12:03:42 +0200
> Subject: [PATCH] gnu: Add hdt-cpp.
> 
> * gnu/packages/rdf.scm (hdt-cpp): New variable.

Thanks! Looks good to me.

I'll need to add you to the list of authors of 'gnu/packages/rdf.scm'.
Should I credit you as "pukkamustard <pukkamustard@posteo.net>"?
pukkamustard Aug. 29, 2020, 6:01 a.m. UTC | #2
> Thanks! Looks good to me.

Woo-hoo!

> I'll need to add you to the list of authors of 
> 'gnu/packages/rdf.scm'.
> Should I credit you as "pukkamustard <pukkamustard@posteo.net>"?

Yes, that is perfect.

Thanks!
-pukkamustard
Leo Famulari Aug. 29, 2020, 6:27 p.m. UTC | #3
On Sat, Aug 29, 2020 at 08:01:20AM +0200, pukkamustard wrote:
> > I'll need to add you to the list of authors of 'gnu/packages/rdf.scm'.
> > Should I credit you as "pukkamustard <pukkamustard@posteo.net>"?
> 
> Yes, that is perfect.

Great! Pushed as 4aaa27e4d2d9edbd919a1e87eb8e9c0feb895444
diff mbox series

Patch

From e1033cab6f57503fdc5d08637058ca74e039a429 Mon Sep 17 00:00:00 2001
From: pukkamustard <pukkamustard@posteo.net>
Date: Fri, 28 Aug 2020 12:03:42 +0200
Subject: [PATCH] gnu: Add hdt-cpp.

* gnu/packages/rdf.scm (hdt-cpp): New variable.
---
 gnu/packages/rdf.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index e68e57818d..13c0cc6011 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -54,6 +54,35 @@ 
   #:use-module (gnu packages tls)
   #:use-module (gnu packages xml))
 
+(define-public hdt-cpp
+  (package
+    (name "hdt-cpp")
+    (version "1.3.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/rdfhdt/hdt-cpp")
+                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1vsq80jnix6cy78ayag7v8ajyw7h8dqyad1q6xkf2hzz3skvr34z"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("serd" ,serd)
+       ("zlib" ,zlib)))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/rdfhdt/hdt-cpp")
+    (synopsis "C++ implementation of the HDT compression format")
+    (description "Header Dictionary Triples (HDT) is a compression format for
+RDF data that can also be queried for Triple Patterns.  This package provides a
+C++ library as well as various command-line tools to to work with HDT.")
+(license license:lgpl2.1+)))
+
 (define-public raptor2
   (package
     (name "raptor2")
-- 
2.28.0