diff mbox series

[bug#44045,08/10,v2] WIP Ultimaker Cura

Message ID 86wnzjk6l8.fsf@gmail.com
State Accepted
Headers show
Series None | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Malte Frank Gerdes Oct. 21, 2020, 2:16 p.m. UTC
This is the updated definition for python-pyinstrument-cext :)


Malte
diff mbox series

Patch

From 8cd0fb113041b792b48834c07dd6765ecf80baf6 Mon Sep 17 00:00:00 2001
From: Malte Frank Gerdes <malte.f.gerdes@gmail.com>
Date: Sat, 17 Oct 2020 12:02:05 +0200
Subject: [PATCH] gnu: Add python-pyinstrument-cext.

* gnu/packages/python-check.scm (python-pyinstrument-cext): New variable.
---
 gnu/packages/python-check.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 498f495584..f62121cf1b 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2020 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -82,6 +83,24 @@  This package provides seamless integration with coverage.py (and thus pytest,
 nosetests, etc...) in Python projects.")
     (license license:expat)))
 
+(define-public python-pyinstrument-cext
+  (package
+  (name "python-pyinstrument-cext")
+  (version "0.2.2")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "pyinstrument_cext" version))
+      (sha256
+        (base32 "0nycf7nhx2xzba49m8208agx5xghzxkma3iim5f43h3l3pvjb7pj"))))
+  (build-system python-build-system)
+  (inputs
+   `(("nose" ,python-nose)))
+  (home-page "https://github.com/joerick/pyinstrument_cext")
+  (synopsis "A CPython extension supporting pyinstrument")
+  (description "A CPython extension supporting pyinstrument")
+  (license license:bsd-3)))
+
 (define-public python-vcrpy
   (package
     (name "python-vcrpy")
-- 
2.28.0