diff mbox series

[bug#54269] : gnu: Add web-pixbuf-loader.

Message ID 86wnh73aro.fsf@163.com
State Accepted
Headers show
Series [bug#54269] : gnu: Add web-pixbuf-loader. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Zhu Zihao March 6, 2022, 5:33 a.m. UTC

Comments

Ludovic Courtès March 11, 2022, 10:14 p.m. UTC | #1
Hi,

Zhu Zihao <all_but_last@163.com> skribis:

>>From 5cd861b0cdfc0527f8b2676b46be7d5007fbf9af Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Sun, 6 Mar 2022 13:32:30 +0800
> Subject: [PATCH] gnu: Add webp-pixbuf-loader.
>
> * gnu/packages/gtk.scm (webp-pixbuf-loader): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 5cd861b0cdfc0527f8b2676b46be7d5007fbf9af Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sun, 6 Mar 2022 13:32:30 +0800
Subject: [PATCH] gnu: Add webp-pixbuf-loader.

* gnu/packages/gtk.scm (webp-pixbuf-loader): New variable.
---
 gnu/packages/gtk.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 29302051c1..0abe22d637 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2893,3 +2893,29 @@  (define-public gromit-mpx
      "Gromit-MPX is an on-screen annotation tool that works with any
 Unix desktop environment under X11 as well as Wayland.")
     (license license:gpl2+)))
+
+(define-public webp-pixbuf-loader
+  (package
+    (name "webp-pixbuf-loader")
+    (version "0.0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/aruiz/webp-pixbuf-loader")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1kshsz91mirjmnmv796nba1r8jg8a613anhgd38dhh2zmnladcwn"))))
+    (build-system meson-build-system)
+    (arguments
+     (list
+      #:configure-flags
+      #~(list (string-append "-Dgdk_pixbuf_moduledir="
+                             #$output "/lib/gdk-pixbuf-2.0/2.10.0/loaders"))))
+    (inputs (list gdk-pixbuf glib gtk+ libwebp))
+    (native-inputs (list pkg-config))
+    (home-page "https://github.com/aruiz/webp-pixbuf-loader")
+    (synopsis "WebP GdkPixbuf loader library")
+    (description "Webp-pixbuf-loader is a WebP format loader of GdkPixbuf.")
+    (license license:lgpl2.0+)))
-- 
2.34.0