diff mbox series

[bug#57174] Use gitlab url for softwares created by Göran Weinholt.

Message ID 86v8qwkzqj.fsf@163.com
State Accepted
Headers show
Series [bug#57174] Use gitlab url for softwares created by Göran Weinholt. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Zhu Zihao Aug. 13, 2022, 2:02 p.m. UTC
Göran Weinholt, the creator of loko-scheme and some other r6rs
libraries, had moved all his project from Github to Gitlab.

These patches update the link of packages to the Gitlab.  

From aeb2379a40757ef5ee7e4ae1344700af99a0ac41 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 13 Aug 2022 13:39:54 +0800
Subject: [PATCH 1/6] gnu: guile-hashing: Use source from Gitlab.

* gnu/packages/guile-xyz.scm (guile-hashing)[home-page]: Use source from
Gitlab.
[source]: Replace missing git tag with commit.
---
 gnu/packages/guile-xyz.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

宋文武 Aug. 15, 2022, 5:57 a.m. UTC | #1
Zhu Zihao <all_but_last@163.com> writes:

> Göran Weinholt, the creator of loko-scheme and some other r6rs
> libraries, had moved all his project from Github to Gitlab.
>
> These patches update the link of packages to the Gitlab.  
>

Pushed, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 8e8a73ad30..fa6230b81c 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3703,12 +3703,12 @@  (define-public guile-hashing
   (package
     (name "guile-hashing")
     (version "1.2.0")
-    (home-page "https://github.com/weinholt/hashing")
+    (home-page "https://gitlab.com/weinholt/hashing")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url home-page)
-                    (commit (string-append "v" version))))
+                    (commit "f138deaec38d54ddb621c082764ece276deebe7f")))
               (file-name (git-file-name name version))
               (sha256
                (base32
-- 
2.37.1

From 649e07225b2ebe14ba60def1e0459568fe258faf Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 13 Aug 2022 13:41:04 +0800
Subject: [PATCH 2/6] gnu: guile-packrat: Use source from Gitlab.

* gnu/packages/guile-xyz.scm (guile-packrat)[home-page]: Use source from
Gitlab.
[source]: Replace missing git tag with commit.
---
 gnu/packages/guile-xyz.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index fa6230b81c..7812cc9003 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3761,12 +3761,12 @@  (define-public guile-packrat
   (package
     (name "guile-packrat")
     (version "0.1.1")
-    (home-page "https://github.com/weinholt/packrat")
+    (home-page "https://gitlab.com/weinholt/packrat")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url home-page)
-                    (commit (string-append "v" version))))
+                    (commit "4201ebe741b605db58a21d70195cfb7db3c38eae")))
               (file-name (git-file-name name version))
               (sha256
                (base32
-- 
2.37.1

From 18b274b80a752292bb659c038517352b65490469 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 13 Aug 2022 13:41:21 +0800
Subject: [PATCH 3/6] gnu: guile-struct-pack: Use source from Gitlab.

* gnu/packages/guile-xyz.scm (guile-struct-pack)
[source]: Use source from Gitlab. Replace missing git tag with commit.
[home-page]: Use source from Gitlab.
---
 gnu/packages/guile-xyz.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 7812cc9003..c7724607a5 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4176,8 +4176,8 @@  (define-public guile-struct-pack
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/weinholt/struct-pack")
-             (commit (string-append "v" version))))
+             (url "https://gitlab.com/weinholt/struct-pack")
+             (commit "11b71963793ed4a3bf761efdd83cf2fe123239ee")))
        (file-name (git-file-name name version))
        (sha256
         (base32 "0hd72m821pahjphzyjn26i55542v8makr55xzjll2cycja4wsbc1"))))
@@ -4205,7 +4205,7 @@  (define files
                       #t)))))
     (native-inputs
      (list guile-3.0))
-    (home-page "https://github.com/weinholt/struct-pack")
+    (home-page "https://gitlab.com/weinholt/struct-pack")
     (synopsis "R6RS library for working with packed byte structures")
     (description
      "This is an R6RS library for working with packed byte structures.  It is
-- 
2.37.1

From d7b259dd2167c3ee160656cb965be41cd965473a Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 13 Aug 2022 13:42:38 +0800
Subject: [PATCH 4/6] gnu: guile-machine-code: Use source from Gitlab.

* gnu/packages/guile-xyz.scm (guile-machine-code)
[source]: Use source from Gitlab.
[home-page]: Use source from Gitlab.
---
 gnu/packages/guile-xyz.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index c7724607a5..c058bef116 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4220,7 +4220,7 @@  (define-public guile-machine-code
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/weinholt/machine-code")
+             (url "https://gitlab.com/weinholt/machine-code")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
@@ -4251,7 +4251,7 @@  (define files
      (list guile-3.0))
     (propagated-inputs
      (list guile-struct-pack))
-    (home-page "https://github.com/weinholt/machine-code")
+    (home-page "https://gitlab.com/weinholt/machine-code")
     (synopsis "Tools that relate to machine code and object formats")
     (description
      "This project is about the development of tools that relate to machine
-- 
2.37.1

From 38592746c06803c5d11b20a9f962123511b2b0b6 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 13 Aug 2022 13:42:51 +0800
Subject: [PATCH 5/6] gnu: guile-laesare: Use source from Gitlab.

* gnu/packages/guile-xyz.scm (guile-laesare)
[source]: Use source from Gitlab.
[home-page]: Use source from Gitlab.
---
 gnu/packages/guile-xyz.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index c058bef116..4498255c89 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4268,7 +4268,7 @@  (define-public guile-laesare
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/weinholt/laesare")
+             (url "https://gitlab.com/weinholt/laesare")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
@@ -4297,7 +4297,7 @@  (define files
                       #t)))))
     (native-inputs
      (list guile-3.0))
-    (home-page "https://github.com/weinholt/laesare")
+    (home-page "https://gitlab.com/weinholt/laesare")
     (synopsis "R6RS Scheme library that provides a reader")
     (description
      "This is an R6RS Scheme library that provides a reader with some extra
-- 
2.37.1

From f8933cda2fb6d227a0ba1135e8799a3a33a5b081 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 13 Aug 2022 19:59:41 +0800
Subject: [PATCH 6/6] gnu: guile-machine-code: Update to 2.2.0.

* gnu/packages/guile-xyz.scm (guile-machine-code): Update to 2.2.0.
---
 gnu/packages/guile-xyz.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 4498255c89..fc6fa37f73 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4215,7 +4215,7 @@  (define files
 (define-public guile-machine-code
   (package
     (name "guile-machine-code")
-    (version "2.1.0")
+    (version "2.2.0")
     (source
      (origin
        (method git-fetch)
@@ -4224,7 +4224,7 @@  (define-public guile-machine-code
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0wzj3caj2jypzyjqfkfqkvr3kkbjabsnhldv9kvnx9w9qnria5yd"))))
+        (base32 "1yjzpg5p082kg4vaqlwbwddrrhxyxar6gsx9ql72hpwah4ka82h5"))))
     (build-system guile-build-system)
     (arguments
      `(#:compile-flags '("--r6rs" "-Wunbound-variable" "-Warity-mismatch")