diff mbox series

[bug#61941,v2] gnu: emacs-helpful: Update to 0.19.1c98f6f.

Message ID 86v8j9a61i.fsf@conses.eu
State New
Headers show
Series [bug#61941,v2] gnu: emacs-helpful: Update to 0.19.1c98f6f. | expand

Commit Message

Miguel Ángel Moreno March 9, 2023, 10:55 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.19.1c98f6f.
[source]: Remove fix-docstring-test.patch.
[propagated-inputs]: Remove emacs-shut-up.
---
 gnu/packages/emacs-xyz.scm                    | 52 +++++++++----------
 .../emacs-helpful-fix-docstring-test.patch    | 18 -------
 2 files changed, 26 insertions(+), 44 deletions(-)
 delete mode 100644 gnu/packages/patches/emacs-helpful-fix-docstring-test.patch

Comments

Nicolas Goaziou March 17, 2023, 8:25 a.m. UTC | #1
Hello,

conses <contact@conses.eu> writes:

> * gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.19.1c98f6f.
> [source]: Remove fix-docstring-test.patch.
> [propagated-inputs]: Remove emacs-shut-up.

You also need to dereference the patch file in gnu/local.mk.

I did that, updated the commit message and applied your patch.

Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3c067fe16c..fa528432cb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23303,31 +23303,31 @@  (define-public emacs-download-region
       (license license:gpl3+))))
 
 (define-public emacs-helpful
-  (package
-    (name "emacs-helpful")
-    (version "0.19")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/Wilfred/helpful")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0qwsifzsjw95l83m7z07fr9h1sqbhggwmcps1qgbddpan2a8ab8a"))
-       ;; Cherry-picked from upstream, remove when bumping to 0.20.
-       (patches (search-patches "emacs-helpful-fix-docstring-test.patch"))))
-    (build-system emacs-build-system)
-    (propagated-inputs
-     (list emacs-elisp-refs emacs-dash emacs-s emacs-f emacs-shut-up))
-    (native-inputs
-     (list emacs-ert-runner emacs-undercover))
-    (arguments
-     `(#:tests? #t
-       #:test-command '("ert-runner")))
-    (home-page "https://github.com/Wilfred/helpful")
-    (synopsis "More contextual information in Emacs help")
-    (description "@code{helpful} is an alternative to the built-in Emacs help
+  (let ((commit "1c98f6f06a85def5d34c735f8cd407f20cebddf9")
+        (revision "0"))
+    (package
+      (name "emacs-helpful")
+      (version (git-version "0.19" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Wilfred/helpful")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "18b5hjfji51zxjrxhkklxx3j9svk295awmxv8n95mp8ilas2kd3l"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       (list emacs-dash emacs-elisp-refs emacs-f emacs-s))
+      (native-inputs
+       (list emacs-ert-runner emacs-undercover))
+      (arguments
+       `(#:tests? #t
+         #:test-command '("ert-runner")))
+      (home-page "https://github.com/Wilfred/helpful")
+      (synopsis "More contextual information in Emacs help")
+      (description "@code{helpful} is an alternative to the built-in Emacs help
 that provides much more contextual information.
 
 @itemize
@@ -23346,7 +23346,7 @@  (define-public emacs-helpful
 @item Trace, disassemble functions from inside Helpful.  This is discoverable
 and doesn't require memorisation of commands.
 @end itemize\n")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-logview
   (package
diff --git a/gnu/packages/patches/emacs-helpful-fix-docstring-test.patch b/gnu/packages/patches/emacs-helpful-fix-docstring-test.patch
deleted file mode 100644
index de40010fa2..0000000000
--- a/gnu/packages/patches/emacs-helpful-fix-docstring-test.patch
+++ /dev/null
@@ -1,18 +0,0 @@ 
-This patch fixing a build failure has been cherry-picked from upstream.
-Originally submitted as pull request by Erik Šabič.
-See also <https://github.com/Wilfred/helpful/pull/296>.
-diff --git a/test/helpful-unit-test.el b/test/helpful-unit-test.el
-index a07aa8e..8a95129 100644
---- a/test/helpful-unit-test.el
-+++ b/test/helpful-unit-test.el
-@@ -119,7 +119,9 @@ bar")))
-   (should
-    (equal
-     (helpful--docstring #'test-foo-advised t)
--    "Docstring here too.")))
-+    (if (version< emacs-version "28")
-+        "Docstring here too."
-+    "Docstring here too.\n\nThis function has :around advice: `ad-Advice-test-foo-advised'."))))
- 
- (defun test-foo-no-docstring ()
-   nil)