diff mbox series

[bug#53443] gnu: nomad: Fix missing webkit2gtk-4.0 compilation error.

Message ID 86pmokyosy.fsf@163.com
State Accepted
Headers show
Series [bug#53443] gnu: nomad: Fix missing webkit2gtk-4.0 compilation error. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Zhu Zihao Jan. 22, 2022, 11:47 a.m. UTC

Comments

Ludovic Courtès Jan. 24, 2022, 8:58 a.m. UTC | #1
Hi,

Zhu Zihao <all_but_last@163.com> skribis:

>>From 6935b34642d37c3830011087707ad4f12bc39658 Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Sat, 22 Jan 2022 19:42:23 +0800
> Subject: [PATCH] gnu: nomad: Fix missing webkit2gtk-4.0 compilation error.
>
> * gnu/package/guile-xyz.scm (nomad)[arguments]<phases>: Add phase
> 'fix-webkitgtk' to update webkit2gtk-4.0 reference in file 'configure.ac'
> and 'typelib/Makefile.am'.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 6935b34642d37c3830011087707ad4f12bc39658 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 22 Jan 2022 19:42:23 +0800
Subject: [PATCH] gnu: nomad: Fix missing webkit2gtk-4.0 compilation error.

* gnu/package/guile-xyz.scm (nomad)[arguments]<phases>: Add phase
'fix-webkitgtk' to update webkit2gtk-4.0 reference in file 'configure.ac'
and 'typelib/Makefile.am'.
---
 gnu/packages/guile-xyz.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 9a7e7d8ba4..e2cf793acc 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3444,6 +3444,16 @@  (define-public nomad
                   (srfi srfi-26))
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-webkitgtk
+           (lambda _
+             ;; Adapt to the version we have in Guix.
+             (substitute* "configure.ac"
+               (("webkit2gtk-4\\.0") "webkit2gtk-4.1")
+               (("webkit2gtk-web-extension-4\\.0")
+                "webkit2gtk-web-extension-4.1"))
+
+             (substitute* "typelib/Makefile.am"
+               (("WebKit2-4\\.0") "WebKit2-4.1"))))
          (add-before 'check 'start-xorg-server
            (lambda* (#:key inputs #:allow-other-keys)
              ;; The test suite requires a running X server.
-- 
2.34.0