diff mbox series

[bug#54710] gnu: python-gst: Fix the concatenation of install path.

Message ID 86pmlwyfz3.fsf@163.com
State Accepted
Headers show
Series [bug#54710] gnu: python-gst: Fix the concatenation of install path. | expand

Commit Message

Zhu Zihao April 4, 2022, 4:21 p.m. UTC
python-gst install it's component to
/<prefix>/site-packagesgi/overrides, expected to install to
/<prefix>/site-packages/gi/overrides.

This issue is introduced in a5c2e7961c21ef8620ce4cfb3569109fbd694e1e.

This is a patch to fix that issue.

Comments

Ludovic Courtès April 5, 2022, 6:25 p.m. UTC | #1
Zhu Zihao <all_but_last@163.com> skribis:

> python-gst install it's component to
> /<prefix>/site-packagesgi/overrides, expected to install to
> /<prefix>/site-packages/gi/overrides.
>
> This issue is introduced in a5c2e7961c21ef8620ce4cfb3569109fbd694e1e.
>
> This is a patch to fix that issue.
>
>>From a341a2bbdef6fc0362d0e54dd66649005a81d7c9 Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Tue, 5 Apr 2022 00:17:29 +0800
> Subject: [PATCH] gnu: python-gst: Fix the concatenation of install path.
>
> * gnu/packages/gstreamer.scm (python-gst):
> [arguments]:
> <configure-flags>: Add missing leading slash.

Applied, thanks!

I added the reference to the offending commit in the commit log.

Ludo’.
diff mbox series

Patch

From a341a2bbdef6fc0362d0e54dd66649005a81d7c9 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Tue, 5 Apr 2022 00:17:29 +0800
Subject: [PATCH] gnu: python-gst: Fix the concatenation of install path.

* gnu/packages/gstreamer.scm (python-gst):
[arguments]:
<configure-flags>: Add missing leading slash.
---
 gnu/packages/gstreamer.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 8ff8e6242b..8b01c9b04b 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -1076,7 +1076,7 @@  (define-public python-gst
        #:configure-flags
        (list (string-append
               "-Dpygi-overrides-dir="
-              (python:site-packages %build-inputs %outputs) "gi/overrides"))))
+              (python:site-packages %build-inputs %outputs) "/gi/overrides"))))
     (native-inputs
      (list pkg-config python))
     (propagated-inputs
-- 
2.34.0