[bug#54710] gnu: python-gst: Fix the concatenation of install path.
Commit Message
python-gst install it's component to
/<prefix>/site-packagesgi/overrides, expected to install to
/<prefix>/site-packages/gi/overrides.
This issue is introduced in a5c2e7961c21ef8620ce4cfb3569109fbd694e1e.
This is a patch to fix that issue.
Comments
Zhu Zihao <all_but_last@163.com> skribis:
> python-gst install it's component to
> /<prefix>/site-packagesgi/overrides, expected to install to
> /<prefix>/site-packages/gi/overrides.
>
> This issue is introduced in a5c2e7961c21ef8620ce4cfb3569109fbd694e1e.
>
> This is a patch to fix that issue.
>
>>From a341a2bbdef6fc0362d0e54dd66649005a81d7c9 Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Tue, 5 Apr 2022 00:17:29 +0800
> Subject: [PATCH] gnu: python-gst: Fix the concatenation of install path.
>
> * gnu/packages/gstreamer.scm (python-gst):
> [arguments]:
> <configure-flags>: Add missing leading slash.
Applied, thanks!
I added the reference to the offending commit in the commit log.
Ludo’.
From a341a2bbdef6fc0362d0e54dd66649005a81d7c9 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Tue, 5 Apr 2022 00:17:29 +0800
Subject: [PATCH] gnu: python-gst: Fix the concatenation of install path.
* gnu/packages/gstreamer.scm (python-gst):
[arguments]:
<configure-flags>: Add missing leading slash.
---
gnu/packages/gstreamer.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
@@ -1076,7 +1076,7 @@ (define-public python-gst
#:configure-flags
(list (string-append
"-Dpygi-overrides-dir="
- (python:site-packages %build-inputs %outputs) "gi/overrides"))))
+ (python:site-packages %build-inputs %outputs) "/gi/overrides"))))
(native-inputs
(list pkg-config python))
(propagated-inputs
--
2.34.0