diff mbox series

[bug#57053] gnu: guile-srfi-158: Update to 0.0.1-0-13126d1. (fix build)

Message ID 86pmh97ow3.fsf@posteo.net
State Accepted
Headers show
Series [bug#57053] gnu: guile-srfi-158: Update to 0.0.1-0-13126d1. (fix build) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard Aug. 9, 2022, 9:17 a.m. UTC
Attached an updated patch that adds guile-3.0 to native-inputs. This
seems to fix cross-compilation. See also discussion for #57055.

-pukkamustard
<pukkamustard@posteo.net> writes:

> Hello Guix,
>
> This updates guile-srfi-158 to a VCS checkout with fixes that were
> causing build failures.
>
> See also: https://gitlab.com/mjbecze/guile-srfi-158/-/merge_requests/1
>
> Best regards,
> pukkamustard
>
> From 52418e221ab1002c83c22d7345d57de116c1a550 Mon Sep 17 00:00:00 2001
> From: pukkamustard <pukkamustard@posteo.net>
> Date: Mon, 8 Aug 2022 10:11:27 +0200
> Subject: [PATCH] gnu: guile-srfi-158: Update to 0.0.1-0-13126d1.
>
> * gnu/packages/guile-xyz.scm (guile-srfi-158): Update to 0.0.1-0-13126d1.
> ---
>  gnu/packages/guile-xyz.scm | 48 ++++++++++++++++++++------------------
>  1 file changed, 25 insertions(+), 23 deletions(-)
>
> diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
> index 3b74540a20..cbdc9c5b66 100644
> --- a/gnu/packages/guile-xyz.scm
> +++ b/gnu/packages/guile-xyz.scm
> @@ -32,7 +32,7 @@
>  ;;; Copyright © 2020 Jesse Gibbons <jgibbons2357@gmail.com>
>  ;;; Copyright © 2020 Mike Rosset <mike.rosset@gmail.com>
>  ;;; Copyright © 2020 Liliana Marie Prikler <liliana.prikler@gmail.com>
> -;;; Copyright © 2020, 2021 pukkamustard <pukkamustard@posteo.net>
> +;;; Copyright © 2020, 2021, 2022 pukkamustard <pukkamustard@posteo.net>
>  ;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
>  ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
>  ;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
> @@ -3116,32 +3116,34 @@ (define-public guile-srfi-145
>      (license license:gpl3+)))
>  
>  (define-public guile-srfi-158
> -  (package
> -    (name "guile-srfi-158")
> -    (version "0.0.1")
> -    (source
> -     (origin
> -       (method git-fetch)
> -       (uri (git-reference
> -             (url "https://gitlab.com/mjbecze/guile-srfi-158.git")
> -             (commit version)))
> -       (sha256
> -        (base32
> -         "0b8hlv1bldbcwkcxi9y8mm6xp5gbgpg7b15bwqxv70iynl9d9a7c"))
> -       (file-name (git-file-name name version))))
> -    (build-system gnu-build-system)
> -    (native-inputs
> -     (list autoconf automake pkg-config))
> -    (inputs
> -     (list guile-3.0))
> -    (home-page "https://gitlab.com/samplet/guile-srfi-158")
> -    (synopsis "SRFI 158 (Generators and Accumulators) for Guile")
> -    (description "This package provides an implementation of SRFI 158
> +  (let ((commit "13126d1ed37892c864337a600a43d6876625fb99")
> +        (revision "0"))
> +    (package
> +      (name "guile-srfi-158")
> +      (version (git-version "0.0.1" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://gitlab.com/mjbecze/guile-srfi-158.git")
> +               (commit commit)))
> +         (sha256
> +          (base32
> +           "0hg57l3w5qamip1clkab0q01np5nqln9y054q39smm4ki0svdl8w"))
> +         (file-name (git-file-name name version))))
> +      (build-system gnu-build-system)
> +      (native-inputs
> +       (list autoconf automake pkg-config))
> +      (inputs
> +       (list guile-3.0))
> +      (home-page "https://gitlab.com/samplet/guile-srfi-158")
> +      (synopsis "SRFI 158 (Generators and Accumulators) for Guile")
> +      (description "This package provides an implementation of SRFI 158
>  for Guile.  SRFI 158 defines utility procedures that create,
>  transform, and consume generators.  It also defines procedures that
>  return accumulators.  It is implemented by wrapping the sample
>  implementation in a thin Guile compatibility layer.")
> -    (license license:gpl3+)))
> +      (license license:gpl3+))))
>  
>  (define-public guile-srfi-159
>    (let ((commit "1bd98abda2ae4ef8f36761a167903e55c6bda7bb")

Comments

Mathieu Othacehe Aug. 11, 2022, 7:51 a.m. UTC | #1
> * gnu/packages/guile-xyz.scm (guile-srfi-158): Update to 0.0.1-0-13126d1.

Pushed, thanks!

Mathieu
diff mbox series

Patch

From 1f4f3bb8dc0f71365d9e576fe4c0572163afc49e Mon Sep 17 00:00:00 2001
From: pukkamustard <pukkamustard@posteo.net>
Date: Mon, 8 Aug 2022 10:11:27 +0200
Subject: [PATCH] gnu: guile-srfi-158: Update to 0.0.1-0-13126d1.

* gnu/packages/guile-xyz.scm (guile-srfi-158): Update to 0.0.1-0-13126d1.
---
 gnu/packages/guile-xyz.scm | 47 +++++++++++++++++++-------------------
 1 file changed, 24 insertions(+), 23 deletions(-)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 3b74540a20..c1aae8791f 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -32,7 +32,7 @@ 
 ;;; Copyright © 2020 Jesse Gibbons <jgibbons2357@gmail.com>
 ;;; Copyright © 2020 Mike Rosset <mike.rosset@gmail.com>
 ;;; Copyright © 2020 Liliana Marie Prikler <liliana.prikler@gmail.com>
-;;; Copyright © 2020, 2021 pukkamustard <pukkamustard@posteo.net>
+;;; Copyright © 2020, 2021, 2022 pukkamustard <pukkamustard@posteo.net>
 ;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
@@ -3116,32 +3116,33 @@  (define-public guile-srfi-145
     (license license:gpl3+)))
 
 (define-public guile-srfi-158
-  (package
-    (name "guile-srfi-158")
-    (version "0.0.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://gitlab.com/mjbecze/guile-srfi-158.git")
-             (commit version)))
-       (sha256
-        (base32
-         "0b8hlv1bldbcwkcxi9y8mm6xp5gbgpg7b15bwqxv70iynl9d9a7c"))
-       (file-name (git-file-name name version))))
-    (build-system gnu-build-system)
-    (native-inputs
-     (list autoconf automake pkg-config))
-    (inputs
-     (list guile-3.0))
-    (home-page "https://gitlab.com/samplet/guile-srfi-158")
-    (synopsis "SRFI 158 (Generators and Accumulators) for Guile")
-    (description "This package provides an implementation of SRFI 158
+  (let ((commit "13126d1ed37892c864337a600a43d6876625fb99")
+        (revision "0"))
+    (package
+      (name "guile-srfi-158")
+      (version (git-version "0.0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://gitlab.com/mjbecze/guile-srfi-158.git")
+               (commit commit)))
+         (sha256
+          (base32
+           "0hg57l3w5qamip1clkab0q01np5nqln9y054q39smm4ki0svdl8w"))
+         (file-name (git-file-name name version))))
+      (build-system gnu-build-system)
+      (native-inputs
+       (list guile-3.0 autoconf automake pkg-config))
+      (inputs (list guile-3.0))
+      (home-page "https://gitlab.com/samplet/guile-srfi-158")
+      (synopsis "SRFI 158 (Generators and Accumulators) for Guile")
+      (description "This package provides an implementation of SRFI 158
 for Guile.  SRFI 158 defines utility procedures that create,
 transform, and consume generators.  It also defines procedures that
 return accumulators.  It is implemented by wrapping the sample
 implementation in a thin Guile compatibility layer.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public guile-srfi-159
   (let ((commit "1bd98abda2ae4ef8f36761a167903e55c6bda7bb")
-- 
2.37.1