diff mbox series

[bug#62199,v4] gnu: Add emacs-fdroid.

Message ID 86pm921j5i.fsf@conses.eu
State New
Headers show
Series [bug#62199,v4] gnu: Add emacs-fdroid. | expand

Commit Message

Miguel Ángel Moreno March 21, 2023, 10:41 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-fdroid): New variable.
---
 gnu/packages/emacs-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Nicolas Goaziou March 24, 2023, 9:19 a.m. UTC | #1
Hello,

conses <contact@conses.eu> writes:

> * gnu/packages/emacs-xyz.scm (emacs-fdroid): New variable.

[...]

> +  #:use-module (gnu packages android)

I cannot build this package. In particular, the line above seems to
generate a backtrace. It may not be related to your patch, though.

Can you reproduce this?

Regards,
Miguel Ángel Moreno June 8, 2023, 7:12 p.m. UTC | #2
On 2023-03-24 10:19, Nicolas Goaziou wrote:

> Hello,
>
> conses <contact@conses.eu> writes:
>
>> * gnu/packages/emacs-xyz.scm (emacs-fdroid): New variable.
>
> [...]
>
>> +  #:use-module (gnu packages android)
>
> I cannot build this package. In particular, the line above seems to
> generate a backtrace. It may not be related to your patch, though.
>
> Can you reproduce this?
>

I used to have this problem not so long ago too, but it seems to have
been fixed, as the package builds successfully now.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b1f72ee009..7b625a67b3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -157,6 +157,7 @@  (define-module (gnu packages emacs-xyz)
   #:use-module (guix build-system trivial)
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
+  #:use-module (gnu packages android)
   #:use-module (gnu packages aspell)
   #:use-module (gnu packages audio)
   #:use-module (gnu packages bash)
@@ -6137,6 +6138,36 @@  (define-public emacs-fd
 result.")
     (license license:gpl3+)))
 
+(define-public emacs-fdroid
+  (package
+    (name "emacs-fdroid")
+    (version "0.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~conses/fdroid.el")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1pmf9j9qcn71hjqdxqgdqf970irp75588nwnn234mapwqvx5v744"))))
+    (build-system emacs-build-system)
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'patch-file-name
+                     (lambda* (#:key inputs #:allow-other-keys)
+                       (emacs-substitute-variables "fdroid.el"
+                         ("fdroid-program"
+                          (search-input-file inputs "/bin/fdroidcl"))))))))
+    (inputs (list fdroidcl))
+    (home-page "https://git.sr.ht/~conses/fdroid.el")
+    (synopsis "Manage F-Droid packages from Emacs")
+    (description "This package is an Emacs interface to F-Droid.  Its purpose
+is to aid in the management of F-Droid packages for an Android device or an
+emulator inside the comfort of Emacs.")
+    (license license:gpl3+)))
+
 (define-public emacs-ripgrep
   (package
     (name "emacs-ripgrep")