diff mbox series

[bug#63925] gnu: emacs-ytdl: Update to 1.3.6-0.2ea3daf2.

Message ID 86pm69osa6.fsf@mianmoreno.com
State New
Headers show
Series [bug#63925] gnu: emacs-ytdl: Update to 1.3.6-0.2ea3daf2. | expand

Commit Message

Miguel Ángel Moreno June 6, 2023, 9:26 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-ytdl): Update to 1.3.6-0.2ea3daf2.
---
This hotfix version fixes a problem with asynchronous downloads when
using other binaries such as yt-dlp (the defacto youtube-dl CLI now)

 gnu/packages/emacs-xyz.scm | 70 ++++++++++++++++++++------------------
 1 file changed, 36 insertions(+), 34 deletions(-)

Comments

Nicolas Goaziou June 10, 2023, 6:45 p.m. UTC | #1
Hello,

Miguel Ángel Moreno <me@mianmoreno.com> writes:

> * gnu/packages/emacs-xyz.scm (emacs-ytdl): Update to 1.3.6-0.2ea3daf2.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cad9819a5e..731d67a851 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26864,43 +26864,45 @@  (define-public emacs-youtube-dl
       (license license:unlicense))))
 
 (define-public emacs-ytdl
-  (package
-    (name "emacs-ytdl")
-    (version "1.3.6")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://gitlab.com/tuedachu/ytdl")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "010arhvibyw50lqhsr8bm0vj3pzry1h1vgcvxnmyryirk3dv40jl"))))
-    (build-system emacs-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'configure
-           (lambda* (#:key inputs #:allow-other-keys)
-             ;; .el is read-only in git.
-             (make-file-writable "ytdl.el")
-             ;; Specify the absolute file names of the various programs so
-             ;; that everything works out-of-the-box.
-             (emacs-substitute-variables "ytdl.el"
-               ("ytdl-command"
-                (search-input-file inputs "/bin/youtube-dl"))))))))
-    (inputs
-     (list youtube-dl))
-    (propagated-inputs
-     (list emacs-async emacs-dash))
-    (home-page "https://gitlab.com/tuedachu/ytdl")
-    (synopsis "Emacs interface for youtube-dl")
-    (description
-     "This package manages a video download queue for @command{youtube-dl},
+  (let ((commit "2ea3daf2f6aa9d18b71fe3e15f05c30a56fca228")
+        (revision "0"))
+    (package
+      (name "emacs-ytdl")
+      (version (git-version "1.3.6" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://gitlab.com/tuedachu/ytdl")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0y62lkgsg19j05dpd6sp6zify8vq8xvpc8caqiy4rwi7p4ahacsf"))))
+      (build-system emacs-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'configure
+             (lambda* (#:key inputs #:allow-other-keys)
+               ;; .el is read-only in git.
+               (make-file-writable "ytdl.el")
+               ;; Specify the absolute file names of the various programs so
+               ;; that everything works out-of-the-box.
+               (emacs-substitute-variables "ytdl.el"
+                 ("ytdl-command"
+                  (search-input-file inputs "/bin/youtube-dl"))))))))
+      (inputs
+       (list youtube-dl))
+      (propagated-inputs
+       (list emacs-async emacs-dash))
+      (home-page "https://gitlab.com/tuedachu/ytdl")
+      (synopsis "Emacs interface for youtube-dl")
+      (description
+       "This package manages a video download queue for @command{youtube-dl},
 which serves as the back end.  New videos can be queued at any time.  All
 youtube-dl backends are supported.  It is possible to create download profiles
 depending on the downloaded URL.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-ytel
   ;; No tagged releases.  Using version from main file.