diff mbox series

[bug#70257] gnu: babl: Disable failing test on aarch64.

Message ID 86pluqmsd7.fsf@burningswell.com
State New
Headers show
Series [bug#70257] gnu: babl: Disable failing test on aarch64. | expand

Commit Message

Roman Scherer April 15, 2024, 5:46 p.m. UTC
Hi Christopher,

thanks for looking into this. Building babl fails on my Apple M1. I
attached a new patch that contains the build error message in the
commit.

Roman
Christopher Baines <mail@cbaines.net> writes:

> Roman Scherer <roman@burningswell.com> writes:
>
>> * gnu/packages/gimp.scm (babl): Disable failing test on aarch64.
>>
>> Change-Id: Icf2c2a9ea5986149902f741f96d1847d2403c1f4
>> ---
>>  gnu/packages/gimp.scm | 12 ++++++++++--
>>  1 file changed, 10 insertions(+), 2 deletions(-)
>
> QA doesn't show any test failure being fixed.
>
> Do you see this happening just some of the time, or only in some
> situations? Also, can you include more information in the commit/a
> comment about the specific failure?
>
> Thanks,
>
> Chris

Comments

Christopher Baines April 17, 2024, 5:10 p.m. UTC | #1
Roman Scherer <roman.scherer@burningswell.com> writes:

> Hi Christopher,
>
> thanks for looking into this. Building babl fails on my Apple M1. I
> attached a new patch that contains the build error message in the
> commit.

Thanks, I've pushed this to master as
e1fefe84aa73d6d48ab43f7c613c7bc6d14d082f.

Chris
diff mbox series

Patch

From 8f4903b08d792eb6948685073df1c1e1c6fa1ade Mon Sep 17 00:00:00 2001
Message-ID: <8f4903b08d792eb6948685073df1c1e1c6fa1ade.1713203117.git.roman@burningswell.com>
From: Roman Scherer <roman@burningswell.com>
Date: Sun, 7 Apr 2024 14:05:39 +0200
Subject: [PATCH v2] gnu: babl: Disable failing test on aarch64.

* gnu/packages/gimp.scm (babl): Disable failing test on aarch64.

Change-Id: Icf2c2a9ea5986149902f741f96d1847d2403c1f4

---

The float-to-8bit test fails on an Apple M1 (aarch64) with the following message:

 9/28 float-to-8bit                   FAIL            0.11s   exit status 1
>>> LD_LIBRARY_PATH=/tmp/guix-build-babl-0.1.108.drv-0/build/babl BABL_PATH=/tmp/guix-build-babl-0.1.108.drv-0/build/extensions MALLOC_PERTURB_=94 /tmp/guix-build-babl-0.1.108.drv-0/build/tests/float-to-8bit
????????????????????????????????????? ?  ?????????????????????????????????????
stdout:
 float -> u8 1 failed #1[1]  got 76 expected 77
stderr:
        " 0x43b9f0 0x4390b0 1"  1541377792      BablFishPath
                cost:146.000000 error:0.000000000000
        "/tmp/guix-build-babl-0.1.108.drv-0/build/extensions/gggl.so 0: R'G'B'A float to R'G'B'A u8"    0       BablConversionLinear
                pixels:0
                error: 0.000000
??????????????????????????????????????????????????????????????????????????????
---
 gnu/packages/gimp.scm | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index b458a6397c..bcc18ad3cf 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -193,8 +193,16 @@  (define-public babl
                 "0x8lxvnhfpssj84x47y3y06vsvhd5afb9jknw38c8ymbxafzxpi6"))))
     (build-system meson-build-system)
     (arguments
-     `(#:configure-flags
-       (list "-Dwith-docs=false")))
+     (list
+      #:configure-flags #~(list "-Dwith-docs=false")
+      #:phases
+      #~(modify-phases %standard-phases
+          #$@(if (target-aarch64?)
+                 #~((add-after 'unpack 'disable-failing-test
+                      (lambda _
+                        (substitute* "tests/meson.build"
+                          (("'float-to-8bit',") "")))))
+                 '()))))
     (native-inputs
      (list gobject-introspection pkg-config vala))
     (propagated-inputs

base-commit: a8353e9d6b34fd8d42d2e8f14ce844849fe9c293
prerequisite-patch-id: 0250f6d992ee74e81797cb1266771a825226fa0b
prerequisite-patch-id: e03a4f63a64eda0c1f229e0b92d130a9beadefa5
prerequisite-patch-id: 09e6b4e8c70f5eb7996f78194c59245f38d3241b
prerequisite-patch-id: a12882ccf5bbef1edbd1110f128cd107f84a1377
prerequisite-patch-id: 2c83a46f3bcf9d3e153e2543fe9a57e5f33af286
prerequisite-patch-id: 3c1ca4618ff254748694208007768994f8f3f180
prerequisite-patch-id: c6c55378dfbf74f5862c5b5609fe7cc3dc4b52d7
prerequisite-patch-id: 6307af77f1d5ccaef3accfce06479f604cdfd260
prerequisite-patch-id: 1f06621d95d4b22729a1461bca01feeb0d491324
prerequisite-patch-id: 2b5ca4e046c327f00c14fb9a0b7a08b6e4014bcb
prerequisite-patch-id: 7ebd64a45f6032d0fa2317d3b276cd93544ea187
-- 
2.41.0