diff mbox series

[bug#61009,v2] Building Icecat and jemalloc on aarch64-linux

Message ID 86mt5s9i3a.fsf@burningswell.com
State New
Headers show
Series [bug#61009,v2] Building Icecat and jemalloc on aarch64-linux | expand

Commit Message

Roman Scherer Feb. 5, 2023, 4:35 p.m. UTC
Hi Guix,

here is another approach to this. This patch series updates jemalloc to
v5.3.0 and does not disable transparent huge pages on aarch64-linux,
similar to what we do on i686-linux and x86_64-linux. So I think this
would support now building binaries for Rust and Icecat on CI for 4K but
also larger kernel page sizes.

Could you please review the patches?

Thanks, Roman.
diff mbox series

Patch

From 0311f5812ab091dabb0686a6373c0d17e006e0c5 Mon Sep 17 00:00:00 2001
From: r0man <roman@burningswell.com>
Date: Sun, 5 Feb 2023 11:01:17 +0100
Subject: [PATCH 3/3] gnu: icecat: Remove unsupported --disable-eme option on
 aarch64.

* gnu/packages/gnuzilla.scm (icecat): Remove unsupported --disable-eme option on aarch64.
---
 gnu/packages/gnuzilla.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index b507ec0406..ad051e71f7 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -756,7 +756,8 @@  (define-public icecat
          "--disable-tests"
          "--disable-updater"
          "--disable-crashreporter"
-         "--disable-eme"
+         ;; The --disable-eme option is not available on aarch64.
+         #$(if (target-aarch64?) "" "--disable-eme")
 
          ;; Building with debugging symbols takes ~5GiB, so disable it.
          "--disable-debug"
-- 
2.38.1