diff mbox series

[bug#54736] gnu: Add python-sre-yield.

Message ID 86lewjwdex.fsf@polidoro.io
State Accepted
Headers show
Series [bug#54736] gnu: Add python-sre-yield. | expand

Commit Message

Peter Polidoro April 5, 2022, 7:13 p.m. UTC

Comments

Ludovic Courtès April 18, 2022, 9:24 p.m. UTC | #1
Peter Polidoro <peter@polidoro.io> skribis:

>>From a15393c931f77aca08f4129a59b864505b5cf884 Mon Sep 17 00:00:00 2001
> From: Peter Polidoro <peter@polidoro.io>
> Date: Tue, 5 Apr 2022 15:12:57 -0400
> Subject: [PATCH] gnu: Add python-sre-yield.
>
> * gnu/packages/python-xyz.scm (python-sre-yield): New variable.

[...]

> +    (propagated-inputs (list python-nose))
> +    (home-page "https://github.com/google/sre_yield")
> +    (synopsis "Expands a regular expression to its possible matches")
> +    (description "Expands a regular expression to its possible matches")
> +    (license #f)))

Pushed with minor tweaks, some suggested by ‘guix lint’: inputs,
description, and license.

Thanks,
Ludo’.
diff mbox series

Patch

From a15393c931f77aca08f4129a59b864505b5cf884 Mon Sep 17 00:00:00 2001
From: Peter Polidoro <peter@polidoro.io>
Date: Tue, 5 Apr 2022 15:12:57 -0400
Subject: [PATCH] gnu: Add python-sre-yield.

* gnu/packages/python-xyz.scm (python-sre-yield): New variable.
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 30cab6a113..0ad31b7b0d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -118,6 +118,7 @@ 
 ;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
 ;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
 ;;; Copyright © 2022 drozdov <drozdov@portalenergy.tech>
+;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29364,3 +29365,20 @@  (define-public python-aiopg
 database from the asyncio (PEP-3156/tulip) framework.  It wraps
 asynchronous features of the Psycopg database driver.")
     (license license:bsd-3)))
+
+(define-public python-sre-yield
+  (package
+    (name "python-sre-yield")
+    (version "1.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "sre_yield" version))
+        (sha256
+          (base32 "12kv3mvdr22g2v9wfr5aabh1f58s817dbh8mrlfzxzxs7hm1lkz9"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-nose))
+    (home-page "https://github.com/google/sre_yield")
+    (synopsis "Expands a regular expression to its possible matches")
+    (description "Expands a regular expression to its possible matches")
+    (license #f)))
-- 
2.35.1