diff mbox series

[bug#59526] gnu: Add whoogle-search.

Message ID 86ilj59syd.fsf@conses.eu
State New
Headers show
Series [bug#59526] gnu: Add whoogle-search. | expand

Commit Message

Miguel Ángel Moreno Nov. 23, 2022, 11 p.m. UTC
* gnu/packages/python-web.scm (whoogle-search): New variable.
---
 gnu/packages/python-web.scm | 56 +++++++++++++++++++++++++++++++++++++
 1 file changed, 56 insertions(+)

Comments

Christopher Baines Nov. 24, 2022, 9:52 a.m. UTC | #1
conses <contact@conses.eu> writes:

> * gnu/packages/python-web.scm (whoogle-search): New variable.
> ---
>  gnu/packages/python-web.scm | 56 +++++++++++++++++++++++++++++++++++++
>  1 file changed, 56 insertions(+)

Thanks! I've pushed this to master as
68113dc2498e507879eeecc583a66a5bc046c91b.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 905d79886f..0178c21ee8 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4743,6 +4743,62 @@  (define-public python-google-api-client
     (description "Python client library for Google's discovery based APIs")
     (license license:asl2.0)))
 
+(define-public whoogle-search
+  (package
+    (name "whoogle-search")
+    (version "0.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "whoogle-search" version))
+              (sha256
+               (base32
+                "0h8cl9bkd3vx17kbvcnmc8cy6pc29lxr0drxm84kj37ka788cj2g"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:tests? #f)) ;needs network
+    (propagated-inputs (list python-attrs
+                             python-beautifulsoup4
+                             python-cachelib
+                             python-certifi
+                             python-cffi
+                             python-brotli
+                             python-chardet
+                             python-click
+                             python-cryptography
+                             python-cssutils
+                             python-defusedxml
+                             python-flask
+                             python-flask-session
+                             python-idna
+                             python-itsdangerous
+                             python-jinja2
+                             python-markupsafe
+                             python-more-itertools
+                             python-packaging
+                             python-pluggy
+                             python-py
+                             python-pycodestyle
+                             python-pycparser
+                             python-pyopenssl
+                             python-pyparsing
+                             python-pysocks
+                             python-dateutil
+                             python-requests
+                             python-soupsieve
+                             python-stem
+                             python-urllib3
+                             python-waitress
+                             python-wcwidth
+                             python-werkzeug
+                             python-dotenv))
+    (home-page "https://github.com/benbusby/whoogle-search")
+    (synopsis "Self-hosted, ad-free, privacy-respecting metasearch engine")
+    (description
+     "Get Google results, but without any ads, javascript, AMP links,
+cookies, or IP address tracking.  Quick and simple to implement as a primary search
+engine replacement on both desktop and mobile.")
+    (license license:expat)))
+
 (define-public python-hawkauthlib
   (package
     (name "python-hawkauthlib")