diff mbox series

[bug#61716] gnu: Add emacs-fontaine.

Message ID 86ilftqwer.fsf@conses.eu
State New
Headers show
Series [bug#61716] gnu: Add emacs-fontaine. | expand

Commit Message

Miguel Ángel Moreno Feb. 22, 2023, 8:26 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-fontaine): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Miguel Ángel Moreno March 6, 2023, 5:44 p.m. UTC | #1
Hi Nicolas,

Just a friendly ping to see if you can review this patch.
Nicolas Goaziou March 7, 2023, 9:58 p.m. UTC | #2
Hello,

conses <contact@conses.eu> writes:

> Just a friendly ping to see if you can review this patch.

Applied (note the hash was wrong, tho). Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3b12642bc9..f0c96c3368 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4006,6 +4006,28 @@  (define-public emacs-font-lock-studio
 the Font Lock keywords.")
       (license license:gpl3+))))
 
+ (define-public emacs-fontaine
+   (package
+     (name "emacs-fontaine")
+     (version "1.0.0")
+     (source (origin
+               (method git-fetch)
+               (uri (git-reference
+                     (url "https://git.sr.ht/~protesilaos/fontaine")
+                     (commit version)))
+               (file-name (git-file-name name version))
+               (sha256
+                (base32
+                 "17zax5bm6ym4jx0wi2daydmq92k4rl9r7v6xmnajbdv1brbmgiqr"))))
+     (build-system emacs-build-system)
+     (home-page "https://sr.ht/~protesilaos/fontaine")
+     (synopsis "Set Emacs font configurations using presets")
+     (description
+      "Fontaine lets the user specify presets of font configurations
+and set them on demand on graphical Emacs frames.  The user option
+@code{fontaine-presets} holds all such presets.")
+     (license license:gpl3+)))
+
 (define-public emacs-form-feed
   (package
     (name "emacs-form-feed")