diff mbox series

[bug#48638] PSOPT (ADOL-C and ColPack)

Message ID 86h7ikj8hz.fsf@hurd.ericcbrown.com
State New
Headers show
Series [bug#48638] PSOPT (ADOL-C and ColPack) | expand

Commit Message

Eric Brown May 30, 2021, 8:02 p.m. UTC
(updated patch set attached)

Hello Prof. Becerra,

Thanks for your response!  I forgot to mention the context of this
message:  I am trying to get PSOPT (and ADOL-C, and ColPack) packaged
for GNU Guix.

Please note that I have updated:
* The homepage URL
* Added gnuplot (not required, but awfully nice :-)

Warm regards,
Eric Brown
Victor Becerra <vmbecerra99@gmail.com> writes:

> Hello
>
> Many thanks for your email.
>
> Yes, I saw there is a problem with the website. Thank you for pointing it out.
>
> Upon investigation, I realized that the credit card I was using for automated payments of the domain
> expired and I did not see the reminders in time, so that the domain lapsed.
>
> I will ask Google to see if they can reinstate it, as there appears to be no easy way to do it
> myself. If that does not work I may have to get a new domain.
>
> As you correctly indicate PSOPT and its documentation can be accessed from the GitHub page.
>
> Best wishes,
>
> Victor Becerra
>
> On Wed, 26 May 2021 at 18:37, Eric Brown <ecbrown@ericcbrown.com> wrote:
>
>  Hello Maxime,
>
>  Thanks for your feedback. Indeed this has only happened recently, as I had been accessing it to
>  learn it.
>
>  I am Cc:'ing the author and see if he knows anything about it.  I think also maybe the GitHub
>  page would work:
>
>  https://github.com/PSOPT/psopt
>
>  Thanks,
>  Eric
>
>  On Wed, May 26, 2021, at 12:24 PM, Maxime Devos wrote:
>  > Eric Brown schreef op di 25-05-2021 om 00:04 [-0500]:
>  > > Patches attached.
>  > 
>  > > +    (home-page "https://psopt.org")
>  > psopt.org is dead. It states:
>  > 
>  > ‘This Domain Name Has Expired - Renewal Instructions’
>  > 
>  > Greetings,
>  > Maxime.
>  > 
>  > Attachments:
>  > * signature.asc
diff mbox series

Patch

From 51982dbb910a688d3faa574a68149902b16a7709 Mon Sep 17 00:00:00 2001
From: Eric Brown <ecbrown@ericcbrown.com>
Date: Mon, 24 May 2021 23:40:05 -0500
Subject: [PATCH 3/3] gnu: psopt: Add psopt.

* gnu/packages/maths.scm (psopt): New variable.
---
 gnu/packages/maths.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6d1d3dc0ca..bca9c086b5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1884,6 +1884,46 @@  function.  It uses C++ overloading to record arithmetic operations, which it
 plays back later in various ways to calculate the requested values.")
     (license license:epl1.0)))
 
+(define-public psopt
+  (package
+    (name "psopt")
+    (version "5.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/PSOPT/psopt")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0y56lag51xdmpcak0wydzrkghypfn884nw8rd62gwgzgxgz0ls9f"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f ; no test suite
+       #:configure-flags
+       `(,(string-append "-Dadolc_INCLUDE_DIR="
+                         (assoc-ref %build-inputs "adol-c") "/include")
+         ,(string-append "-Dadolc_LIBRARY="
+                         (assoc-ref %build-inputs "adol-c") "/lib"))))
+    (native-inputs
+     `(("python-2" ,python-2)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("adol-c" ,adol-c)
+       ("colpack" ,colpack)
+       ("eigen" ,eigen)
+       ("gnuplot" ,gnuplot)
+       ("ipopt" ,ipopt)
+       ("lapack" ,openblas)))
+    (home-page "https://github.com/PSOPT/psopt")
+    (synopsis "Optimal Control Software")
+    (description
+     "PSOPT is an optimal control package written in C++ that uses direct
+collocation methods. These methods solve optimal control problems by
+approximating the time-dependent variables using global or local
+polynomials.")
+    (license license:lgpl2.1)))
+
 (define-public libflame
   (package
     (name "libflame")
-- 
2.32.0.rc0