diff mbox series

[bug#51747] : gnu: nix: Update to 2.4.

Message ID 86h7a664rv.fsf@163.com
State Accepted
Headers show
Series [bug#51747] : gnu: nix: Update to 2.4. | expand

Commit Message

Zhu Zihao Jan. 14, 2022, 9:31 a.m. UTC
Finally solve these issues, I hope.

Comments

M Jan. 14, 2022, 12:56 p.m. UTC | #1
Zhu Zihao schreef op vr 14-01-2022 om 17:31 [+0800]:
> [...]
> +(define-public libcpuid
> +  (let ((commit "2e61160983f32ba840b2246d3c3850c44626ab0d")
> +        (revision "1"))
> +    (package
> +      (name "libcpuid")
> +      (version (git-version "0.5.1" revision commit))

There's a good reason for using an unreleases version here,
but this should ideally be documented with a comment,
maybe

  ;; See <https://github.com/anrieff/libcpuid/pull/159>

> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/anrieff/libcpuid")
> +               (commit commit)))
> +         (sha256
> +          (base32
> "1mphvkiqq6z33sq6i490fq27sbyylacwrf8bg7ccvpcjms208sww"))
> +         (modules '((guix build utils)))
> +         (snippet
> +          ;; Remove blobs
> +          #~(begin
> +              (delete-file "libcpuid/msrdriver.c")
> +              (delete-file-recursively "contrib/MSR Driver")))
> +         (file-name (git-file-name name version))))
> +      (build-system cmake-build-system)
> +      (arguments
> +       (list #:tests? #f))              ;broken

In which manner are they broken?  Maybe they can be fised.

> +      (supported-systems '("x86_64-linux" "i686-linux"))

See my e-mail about target-x86-64? and the Hurd.

> +      (home-page "https://libcpuid.sourceforge.net/")
> +      (synopsis "Small library for x86 CPU detection and feature
> extraction")
> +      (description "Libcpuid is a small C library to get vendor,
> model, branding
> +string, code name and other information from x86 CPU.")

It seems easy to confuse this with the package 'cpuid', maybe you
can mention 'cpuid' and 'libcpuid' are unrelated packages, albeit
for a similar purpose?

Greetings,
Maxime.
diff mbox series

Patch

From 959060f15cd24e0266d5b106dbefb94c1beeccba Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Fri, 14 Jan 2022 17:30:22 +0800
Subject: [PATCH 6/6] gnu: nix: Update to 2.5.1.

* gnu/packages/package-management.scm(nix): Update to 2.5.1.
---
 gnu/packages/package-management.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 594d6e9d4b..9882f0a411 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -662,7 +662,7 @@  (define-public guix-icons
 (define-public nix
   (package
     (name "nix")
-    (version "2.4")
+    (version "2.5.1")
     (source
      (origin
        (method git-fetch)
@@ -671,7 +671,7 @@  (define-public nix
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1abgfw5ndqklm0x533li32l4azifz3f6lhaxm6s74b704043r7m2"))
+        (base32 "1m8rmv8i6lg83pmalvjlq1fn8mcghn3ngjv3kw1kqsa45ymj5sqq"))
        (patches
         (search-patches "nix-dont-build-html-doc.diff"))))
     (build-system gnu-build-system)
-- 
2.34.0