diff mbox series

[bug#43906] Add missing dependencies of Slic3r

Message ID 86ft6m2nou.fsf@gmail.com
State New
Headers show
Series [bug#43906] Add missing dependencies of Slic3r | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Malte Frank Gerdes Oct. 10, 2020, 1:52 p.m. UTC
Hi,

these patches add the missing dependencies for slic3r.


Malte

Comments

Andreas Enge Oct. 10, 2020, 7:53 p.m. UTC | #1
Hello,

On Sat, Oct 10, 2020 at 03:52:17PM +0200, Malte Frank Gerdes wrote:
> Subject: [PATCH 2/7] gnu: Add perl-alien-wxwidgets.

during build, I see the following messages:
starting phase `build'
Building Alien-wxWidgets
'media' library not found: some functionality will be missing

Does this matter? Should we add more inputs?

Then this:
starting phase `check'
t/01_load.t .......... ok
t/zy_pod_coverage.t .. skipped: Test::Pod::Coverage 1.00 required for testing POD coverage
t/zz_pod.t ........... skipped: Test::Pod 1.00 required for testing POD

Similarly, add (native-)inputs?

Concerning these, I ran this command:
$ guix gc --references /gnu/store/r8lbv88cg2nqkk0a2hjcvrs0z3ljqrcy-perl-alien-wxwidgets-0.69
/gnu/store/a41jn9pcrgpkgba6vpd3m56r0fsczsv2-wxwidgets-gtk2-3.0.5.1
/gnu/store/r8lbv88cg2nqkk0a2hjcvrs0z3ljqrcy-perl-alien-wxwidgets-0.69

So wxwidgets-gtk2 should be a normal, non-native input.
Why -gtk2? Does this warrant a comment?

Concerning normal vs. propagated inputs, I must confess my ignorance of perl;
do all perl packages need to be propagated?

I would suggest insignificantly beefed up descriptive fields:
    (synopsis "Module for building, finding and using wxWidgets binaries")
    (description "Alien::wxWidgets can be used to detect and get configuration
settings from an installed wxWidgets package.")

Andreas
Tobias Geerinckx-Rice Oct. 10, 2020, 8:26 p.m. UTC | #2
Andreas,

Andreas Enge 写道:
> Then this:
> starting phase `check'
> t/01_load.t .......... ok
> t/zy_pod_coverage.t .. skipped: Test::Pod::Coverage 1.00 
> required for testing POD coverage
> t/zz_pod.t ........... skipped: Test::Pod 1.00 required for 
> testing POD
>
> Similarly, add (native-)inputs?

I deliberately ignore these when I see them.

Like test coverage or code formatting tests, these test the source 
code (here: documentation) itself, not the build result.  IMO 
that's useful for upstream authors but not for us redistributors.

> Concerning normal vs. propagated inputs, I must confess my 
> ignorance of perl; do all perl packages need to be propagated?

Yes, unless a PERL5LIB wrapper is used instead.  Binaries & 
scripts can be wrapped, Perl modules can't.

Kind regards,

T G-R
diff mbox series

Patch

From 2348760d580539199e99e4a7f3b9141f6c7884f2 Mon Sep 17 00:00:00 2001
From: Malte Frank Gerdes <malte.f.gerdes@gmail.com>
Date: Wed, 7 Oct 2020 18:17:14 +0200
Subject: [PATCH 7/7] gnu: Add perl-wx-glcanvas.

* gnu/packages/perl.scm (perl-wx-glcanvas): New variable.
---
 gnu/packages/perl.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 879fdd4e74..9bf60433e3 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -10913,6 +10913,40 @@  having to write a single line of XS.")
 known as wxWindows) GUI toolkit.")
     (license license:perl-license)))
 
+(define-public perl-wx-glcanvas
+  (package
+    (name "perl-wx-glcanvas")
+    (version "0.09")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/M/MB/MBARBON/Wx-GLCanvas-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1q4gvj4gdx4l8k4mkgiix24p9mdfy1miv7abidf0my3gy2gw5lka"))))
+    (build-system perl-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'pre-check
+           (lambda _
+             ;; Tests require a running X server.
+             (system "Xvfb :1 &")
+             (setenv "DISPLAY" ":1")
+             #t)))))
+    (native-inputs `(("perl-wx" ,perl-wx)
+                     ("xvfb" ,xorg-server-for-tests)))
+    (inputs `(("mesa" ,mesa)))
+    (propagated-inputs `(("perl-wx" ,perl-wx)))
+    (home-page "https://metacpan.org/release/Wx-GLCanvas")
+    (synopsis "interface to wxWidgets' OpenGL canvas")
+    (description "The documentation for this module is included in the main
+wxPerl distribution (wxGLCanvas).")
+    (license license:perl-license)))
+
 (define-public perl-xml-writer
   (package
     (name "perl-xml-writer")
-- 
2.28.0