diff mbox series

[bug#39846] gnu: Add SVT-AV1.

Message ID 86ee9d7584db25cb3f36734e1b1543ffce4c18c8.1583018575.git.leo@famulari.name
State Accepted
Headers show
Series [bug#39846] gnu: Add SVT-AV1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Leo Famulari Feb. 29, 2020, 11:22 p.m. UTC
* gnu/packages/video.scm (svt-av1): New variable.
---
 gnu/packages/video.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Leo Famulari March 14, 2020, 5:03 a.m. UTC | #1
I added a build phase that installs the documentation (markdown files).

Pushed as 554f5b62805b900a9e4e320cbbbb800c13557b7e
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6719e1e047..8d8db4b1ca 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3793,3 +3793,32 @@  Theora videos.  Theorafile was written to be used for FNA's VideoPlayer.")
 DVD using @command{libdvdcss}, but does @strong{not} demux, remux,
 transcode or reformat the videos in any way, producing perfect backups.")
     (license license:gpl3+)))
+
+(define-public svt-av1
+  (package
+    (name "svt-av1")
+    (version "0.8.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/OpenVisualCloud/SVT-AV1.git")
+                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "08sx9zhhks8wzq05f67jqmc1zqmmi7hqkgg2gyjpcsan5qc5476w"))))
+    (build-system cmake-build-system)
+    ;; SVT-AV1 only supports Intel-compatible CPUs.
+    (supported-systems '("x86_64-linux" "i686-linux"))
+    (arguments
+      ;; The test suite tries to download test data and git clone a 3rd-party
+      ;; fork of libaom.  Skip it.
+     '(#:tests? #f))
+    (native-inputs
+     `(("yasm" ,yasm)))
+    (synopsis "AV1 video codec")
+    (description "SVT-AV1 is an AV1 codec implementation.  The encoder is a
+work-in-progress, aiming to support video-on-demand and live streaming
+applications.  It only supports Intel-compatible CPUs (x86).")
+    (home-page "https://github.com/OpenVisualCloud/SVT-AV1")
+    (license license:bsd-2)))