diff mbox series

[bug#59681] Acknowledgement ([PATCH 1/2] gnu: loko: Use G-expressions.)

Message ID 86edtlrczz.fsf@163.com
State New
Headers show
Series [bug#59681] Acknowledgement ([PATCH 1/2] gnu: loko: Use G-expressions.) | expand

Commit Message

Zhu Zihao Nov. 29, 2022, 3:30 p.m. UTC
Something wrong with the original patch, update here

Comments

Ludovic Courtès Dec. 2, 2022, 10:08 p.m. UTC | #1
Hi,

Zhu Zihao <all_but_last@163.com> skribis:

>>From 0d85f05069ccb1bfa648def38375b981893e3601 Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Tue, 29 Nov 2022 18:59:24 +0800
> Subject: [PATCH 1/2] gnu: loko-scheme: Use G-expressions.
>
> * gnu/packages/loko.scm (loko-scheme)[arguments]: Use G-expressions.
> <#:phases>: In 'akku-fixes', replace "(assoc-ref inputs name)" with
> "this-package-native-input".
> [native-inputs]: Use label-less style.

[...]

>>From 907766669a0efdb16631361ee3f225da8a6767f1 Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Tue, 29 Nov 2022 19:27:05 +0800
> Subject: [PATCH 2/2] gnu: loko-scheme: Update to 0.12.0.
>
> * gnu/packages/loko.scm (loko-scheme): Update to 0.12.0.
> [arguments]<#:make-flags>: No need to specify GDB scripts directory.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 907766669a0efdb16631361ee3f225da8a6767f1 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Tue, 29 Nov 2022 19:27:05 +0800
Subject: [PATCH 2/2] gnu: loko-scheme: Update to 0.12.0.

* gnu/packages/loko.scm (loko-scheme): Update to 0.12.0.
[arguments]<#:make-flags>: No need to specify GDB scripts directory.
---
 gnu/packages/loko.scm | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/loko.scm b/gnu/packages/loko.scm
index cb189acb87..49dcc92d1e 100644
--- a/gnu/packages/loko.scm
+++ b/gnu/packages/loko.scm
@@ -18,6 +18,7 @@ 
 
 (define-module (gnu packages loko)
   #:use-module (guix packages)
+  #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module ((guix licenses) #:prefix license:)
@@ -29,7 +30,7 @@  (define-module (gnu packages loko)
 (define-public loko-scheme
   (package
     (name "loko-scheme")
-    (version "0.7.0")
+    (version "0.12.0")
     (source
      (origin
        (method git-fetch)
@@ -37,7 +38,7 @@  (define-public loko-scheme
              (url "https://gitlab.com/weinholt/loko")
              (commit (string-append "v" version))))
        (sha256
-        (base32 "1441aarw3vy14zdxyab495ag2fch04v4j89krhbqnqfkz6mdi0vy"))
+        (base32 "12xp82z91qkp9q8lfp46s4sda8qgs472jic3js1kbykn4jzy7399"))
        (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
@@ -46,9 +47,7 @@  (define-public loko-scheme
       #:tests? #f
       #:strip-binaries? #f
       #:make-flags
-      #~(list
-         (string-append "PREFIX=" #$output)
-         (string-append "GDB_AUTOLOAD_PATH=" #$output "/share/gdb/auto-load"))
+      #~(list (string-append "PREFIX=" #$output))
       #:phases
       #~(modify-phases %standard-phases
           (delete 'configure)
-- 
2.38.1