diff mbox series

[bug#61705] gnu: Add emacs-org-recur.

Message ID 86edqhsvus.fsf@conses.eu
State New
Headers show
Series [bug#61705] gnu: Add emacs-org-recur. | expand

Commit Message

Miguel Ángel Moreno Feb. 22, 2023, 12:55 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-org-recur): New variable.
---
 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Nicolas Goaziou Feb. 22, 2023, 1:54 p.m. UTC | #1
Hello,

conses <contact@conses.eu> writes:

> * gnu/packages/emacs-xyz.scm (emacs-org-recur): New variable.

Thanks.

> +    (synopsis "Simple recurring org-mode tasks")

Nitpick: org-mode —> Org mode

> +    (description "This package extends org-mode and org-agenda with support

Nitpick: org-mode —> Org mode ; org-agenda —> Org Agenda

> +for defining recurring tasks and easily scheduling them.")
> +    (license license:gpl3)))

License is GPL3+.

Upstream includes tests. Could you run them in the package definition?

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3b12642bc9..17fea8012c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20849,6 +20849,27 @@  (define-public emacs-org-recent-headings
 as well as functions for navigating between these headings.")
       (license license:gpl3+))))
 
+(define-public emacs-org-recur
+  (package
+    (name "emacs-org-recur")
+    (version "1.3.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/m-cat/org-recur")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0s2n62y3qc72ldzpaq2jz9335h532s566499n346nx21l4qsqdz6"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-dash))
+    (home-page "https://github.com/m-cat/org-recur")
+    (synopsis "Simple recurring org-mode tasks")
+    (description "This package extends org-mode and org-agenda with support
+for defining recurring tasks and easily scheduling them.")
+    (license license:gpl3)))
+
 (define-public emacs-org-super-agenda
   (package
     (name "emacs-org-super-agenda")