diff mbox series

[bug#61084] gnu: Add emacs-clj-deps-new.

Message ID 86cz716pco.fsf@conses.eu
State New
Headers show
Series [bug#61084] gnu: Add emacs-clj-deps-new. | expand

Commit Message

Miguel Ángel Moreno Jan. 26, 2023, 7:57 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-clj-deps-new): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Nicolas Goaziou Jan. 27, 2023, 8:55 a.m. UTC | #1
Hello,

conses <contact@conses.eu> writes:

> * gnu/packages/emacs-xyz.scm (emacs-clj-deps-new): New variable.

Thank you. Some comments follow.

> +(define-public emacs-clj-deps-new
> +  (package
> +    (name "emacs-clj-deps-new")
> +    (version "20221007.1014")

Version is "1.1" according to "clj-deps-new.el" file.

> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append "https://melpa.org/packages/clj-deps-new-"
> +                                  version ".el"))

Guix doesn't use MELPA as upstream because their tarballs are not
stable. You may use "https://github.com/jpe90/emacs-clj-deps-new" instead.

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dc378581f5..ea65223ac1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11688,6 +11688,28 @@  (define-public emacs-clojure-mode
 It is recommended to use @code{clojure-mode} with Paredit or Smartparens.")
     (license license:gpl3+)))
 
+(define-public emacs-clj-deps-new
+  (package
+    (name "emacs-clj-deps-new")
+    (version "20221007.1014")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://melpa.org/packages/clj-deps-new-"
+                                  version ".el"))
+              (sha256
+               (base32
+                "0hpakpkcrfz1f79fpx1z74kvazwqsflr71szw73zmlys47wcz3pg"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-transient))
+    (home-page "https://github.com/jpe90/emacs-clj-deps-new")
+    (synopsis "Create Clojure projects from templates")
+    (description
+     "This is a small wrapper around the
+@uref{https://github.com/seancorfield/deps-new, deps-new} and
+@uref{https://github.com/seancorfield/clj-new, clj-new} tools for creating
+Clojure projects from templates.")
+    (license license:gpl3)))
+
 (define-public emacs-clj-refactor
   (package
     (name "emacs-clj-refactor")