diff mbox series

[bug#44652] gnu: Add vimix-cursor-theme.

Message ID 86blfzgoyv.fsf@163.com
State New
Headers show
Series [bug#44652] gnu: Add vimix-cursor-theme. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Zhu Zihao Nov. 15, 2020, 5:37 a.m. UTC

Comments

Efraim Flashner Nov. 18, 2020, 9:30 a.m. UTC | #1
Does it make sense to build the icons ourselves? We can either use
build.sh or re-implement it, it doesn't actually look that bad.

On Sun, Nov 15, 2020 at 01:37:28PM +0800, Zhu Zihao wrote:


> From e4268e914aa835f4bf61ad57c2023cc7d7553832 Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Sun, 15 Nov 2020 13:36:47 +0800
> Subject: [PATCH] gnu: Add vimix-cursor-theme.
> 
> * gnu/packages/gnome-xyz.scm(vimix-cursor-theme): New variable.
> ---
>  gnu/packages/gnome-xyz.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
> 
> diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
> index 77b4aada6f..0f2a7d2465 100644
> --- a/gnu/packages/gnome-xyz.scm
> +++ b/gnu/packages/gnome-xyz.scm
> @@ -7,6 +7,7 @@
>  ;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
>  ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
>  ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
> +;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -123,6 +124,28 @@ which haven't been updated for some years.  The new app icons are ported from
>  the Obsidian icon theme.")
>      (license license:gpl3)))
>  
> +(define-public vimix-cursor-theme
> +  (package
> +    (name "vimix-cursor-theme")
> +    (version "2020-02-24")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/vinceliuice/Vimix-cursors")
> +             (commit version)))
> +       (sha256 "0bij0x916lbxph28i3d4hz5l6mzk5fa68mf21jnl7y9rpxx07xsd")))
> +    (build-system copy-build-system)
> +    (arguments
> +     `(#:install-plan
> +       '(("dist/" "/share/icons/vimix-cursor/")
> +         ("dist-white/" "/share/icons/vimix-white-cursor/"))))
> +    (synopsis "Material design inspired cursor theme")
> +    (description "Vimix-cursor-theme is a x-cursor theme inspired by Material
> +design and based on capitaine-cursors.")
> +    (home-page "https://github.com/vinceliuice/Vimix-cursors")
> +    (license license:gpl3+)))
> +
>  (define-public gnome-shell-extension-appindicator
>    (package
>      (name "gnome-shell-extension-appindicator")
> -- 
> 2.29.2
> 

> 
> -- 
> Retrieve my PGP public key: https://meta.sr.ht/~citreu.pgp
> 
> Zihao
diff mbox series

Patch

From e4268e914aa835f4bf61ad57c2023cc7d7553832 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sun, 15 Nov 2020 13:36:47 +0800
Subject: [PATCH] gnu: Add vimix-cursor-theme.

* gnu/packages/gnome-xyz.scm(vimix-cursor-theme): New variable.
---
 gnu/packages/gnome-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 77b4aada6f..0f2a7d2465 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -123,6 +124,28 @@  which haven't been updated for some years.  The new app icons are ported from
 the Obsidian icon theme.")
     (license license:gpl3)))
 
+(define-public vimix-cursor-theme
+  (package
+    (name "vimix-cursor-theme")
+    (version "2020-02-24")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/vinceliuice/Vimix-cursors")
+             (commit version)))
+       (sha256 "0bij0x916lbxph28i3d4hz5l6mzk5fa68mf21jnl7y9rpxx07xsd")))
+    (build-system copy-build-system)
+    (arguments
+     `(#:install-plan
+       '(("dist/" "/share/icons/vimix-cursor/")
+         ("dist-white/" "/share/icons/vimix-white-cursor/"))))
+    (synopsis "Material design inspired cursor theme")
+    (description "Vimix-cursor-theme is a x-cursor theme inspired by Material
+design and based on capitaine-cursors.")
+    (home-page "https://github.com/vinceliuice/Vimix-cursors")
+    (license license:gpl3+)))
+
 (define-public gnome-shell-extension-appindicator
   (package
     (name "gnome-shell-extension-appindicator")
-- 
2.29.2