diff mbox series

[bug#55188] gnu: Add python-vitables.

Message ID 86bkw2aj73.fsf@polidoro.io
State New
Headers show
Series [bug#55188] gnu: Add python-vitables. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Peter Polidoro May 12, 2022, 2:55 p.m. UTC
Hi,

I have made changes you suggested to the description and have 
attached a new patch, thank you.

I tried to get the tests to run, but they have errors and I do not 
know enough yet to fix them myself:

qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" 
even though it was found.

Is it possible to get tests like this to work when building 
packages in isolated environments? Or is it necessary to disable 
these tests?

Thank you for your time!


Mathieu Othacehe <othacehe@gnu.org> writes:

> Hello Peter,
>
>> +    (arguments
>> +     `(#:tests? #f))
>
> You should add a comment stating why the tests are disabled. 
> Because
> there are no tests or because they are failing, and if so why?
>
>> +    (description "ViTables is a GUI for browsing and editing 
>> files in both
>> +PyTables and HDF5 formats. ViTables capabilities include easy 
>> navigation
>> +through the data hierarchy, displaying of real data and its 
>> associated
>> +metadata, a simple, yet powerful, browsing of multidimensional 
>> data and much
>> +more. As a viewer, one of the greatest strengths of ViTables 
>> is its ability to
>> +display very large datasets.")
>> +    (license license:gpl3)))
>
> The description could be more neutral: you could remove the "yet
> powerful" and "much more" parts. The last sentence could also be
> reworded: "As a viewer, ViTables is able to display very large 
> datasets."
> feels more factual.
>
> Could you send an updated patch :) ?
>
> Thanks,
>
> Mathieu
diff mbox series

Patch

From 693b8cf04dfd6a6c74e9d6d232a3a1f8aadb763c Mon Sep 17 00:00:00 2001
Message-Id: <693b8cf04dfd6a6c74e9d6d232a3a1f8aadb763c.1652367274.git.peter@polidoro.io>
From: Peter Polidoro <peter@polidoro.io>
Date: Thu, 12 May 2022 10:53:48 -0400
Subject: [PATCH] gnu: Add python-vitables.

* gnu/packages/python-xyz.scm (python-vitables): New variable.
---
 gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 659538d193..ed6992721b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29884,3 +29884,35 @@  (define-public python-deepmerge
      "The @code{deep-merge} Python library provides a toolset to deeply merge
 nested data structures in Python like lists and dictionaries.")
     (license license:expat)))
+
+(define-public python-vitables
+  (package
+    (name "python-vitables")
+    (version "3.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ViTables" version))
+       (sha256
+        (base32 "1vk80a8jbg0phxgf31rnm7gq34mllv7hb5h0bypz4kv7n3150iln"))))
+    (build-system python-build-system)
+    (native-inputs
+     (list python-pytest
+           qtbase-5))
+    (propagated-inputs
+     (list python-numexpr
+           python-numpy
+           python-pyqt
+           python-qtpy
+           python-tables))
+    ;; tests fail with qt.qpa.xcb: could not connect to display error
+    ;; (arguments
+    ;;  `(#:tests? #f))
+    (home-page "https://vitables.org")
+    (synopsis "GUI for browsing PyTables and HDF5 files")
+    (description "ViTables is a GUI for browsing and editing files in both
+PyTables and HDF5 formats. ViTables capabilities include navigation through
+the data hierarchy, displaying of real data and its associated metadata, and
+browsing of multidimensional data. As a viewer, ViTables is able to display
+very large datasets.")
+    (license license:gpl3)))
-- 
2.36.0