diff mbox series

[bug#62199] gnu: Add emacs-fdroid.

Message ID 86bkkuxld7.fsf@conses.eu
State New
Headers show
Series [bug#62199] gnu: Add emacs-fdroid. | expand

Commit Message

Miguel Ángel Moreno March 15, 2023, 12:14 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-fdroid): New variable.
---
 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Sergey Trofimov March 20, 2023, 10:54 p.m. UTC | #1
Hi conses,
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url 
> "https://git.sr.ht/~conses/fdroid.el";)
> +                    (commit version)))

you have extra `;` in url. The same typo in `(home-page ...)`.
Also, as the package depends on fdroidcl being present, maybe it 
should be added to `propagated-inputs`?
Miguel Ángel Moreno March 21, 2023, 7:50 a.m. UTC | #2
Sergey Trofimov <sarg@sarg.org.ru> writes:

> Hi conses,

Hi Sergey,

>> +              (method git-fetch)
>> +              (uri (git-reference
>> +                    (url "https://git.sr.ht/~conses/fdroid.el";)
>> +                    (commit version)))
>
> you have extra `;` in url. The same typo in `(home-page ...)`.
> Also, as the package depends on fdroidcl being present, maybe it
> should be added to `propagated-inputs`?
>

I personally can't see that typo on my end.  I also double-checked in
mumi <https://issues.guix.gnu.org/62199> and everything seems to be
alright syntax-wise.  Nevertheless, I've added fdroidcl as an input.

Thank you for having a look!
Sergey Trofimov March 21, 2023, 8:21 a.m. UTC | #3
Hi conses,

conses <contact@conses.eu> writes:
> [...]
>
> I personally can't see that typo on my end.  I also 
> double-checked in
> mumi <https://issues.guix.gnu.org/62199> and everything seems to 
> be
> alright syntax-wise.

Yeah, some glitch happened on my end. I don't see it anymore in 
`debbugs` interface.

> Nevertheless, I've added fdroidcl as an input.

Shouldn't it be a `propagated-input`? It's not a build dependency, 
but rather a runtime one.
Sergey Trofimov March 21, 2023, 8:55 a.m. UTC | #4
Hi again,

>> I personally can't see that typo on my end.  I also 
>> double-checked in
>> mumi <https://issues.guix.gnu.org/62199> and everything seems 
>> to be
>> alright syntax-wise.
>
> Yeah, some glitch happened on my end. I don't see it anymore in 
> `debbugs`
> interface.

Actually, this `;` is visible here: 
https://lists.gnu.org/archive/html/guix-patches/2023-03/msg01008.html
Clearly a bug in this interface.
Nicolas Goaziou March 21, 2023, 9:02 a.m. UTC | #5
Hello,

Sergey Trofimov <sarg@sarg.org.ru> writes:


> conses <contact@conses.eu> writes:

>> Nevertheless, I've added fdroidcl as an input.
>
> Shouldn't it be a `propagated-input`? It's not a build dependency, but
> rather a runtime one.

No, `inputs' is fine, but a phase should point `fdroid-program' variable
to the correct executable, thus avoiding propagation.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3c067fe16c..ce5aa10a05 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6070,6 +6070,27 @@  (define-public emacs-fd
 result.")
     (license license:gpl3+)))
 
+(define-public emacs-fdroid
+  (package
+    (name "emacs-fdroid")
+    (version "0.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~conses/fdroid.el")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1pmf9j9qcn71hjqdxqgdqf970irp75588nwnn234mapwqvx5v744"))))
+    (build-system emacs-build-system)
+    (home-page "https://git.sr.ht/~conses/fdroid.el")
+    (synopsis "Manage F-Droid packages from Emacs")
+    (description "This package is an Emacs interface to F-Droid.  Its purpose
+is to aid in the management of F-Droid packages for an Android device or an
+emulator inside the comfort of Emacs.")
+    (license license:gpl3+)))
+
 (define-public emacs-ripgrep
   (package
     (name "emacs-ripgrep")