diff mbox series

[bug#63584] Acknowledgement ([PATCH] gnu: d-feet: Fix the build error when using Meson 1.1.0.)

Message ID 86bkhzwbvn.fsf@163.com
State New
Headers show
Series [bug#63584] Acknowledgement ([PATCH] gnu: d-feet: Fix the build error when using Meson 1.1.0.) | expand

Commit Message

Zhu Zihao June 1, 2023, 1:27 p.m. UTC
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Exactly.  If you wish to apply `guix style' or similar formatting, I
> recommend a follow-up commit.

Done it with -1/+3 :)

Comments

Liliana Marie Prikler June 4, 2023, 6:30 a.m. UTC | #1
Am Donnerstag, dem 01.06.2023 um 21:27 +0800 schrieb Zhu Zihao:
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > Exactly.  If you wish to apply `guix style' or similar formatting,
> > I recommend a follow-up commit.
> 
> Done it with -1/+3 :)
+4 due to copyright, but good enough for me.

Thanks
diff mbox series

Patch

From 954ffef03e1637048b537f704f05d78b823b5806 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Fri, 19 May 2023 19:51:41 +0800
Subject: [PATCH] gnu: d-feet: Fix the build error when using Meson 1.1.0.

Fix the build error:

data/meson.build:15:0: ERROR: Function does not take positional arguments.
data/meson.build:27:0: ERROR: Function does not take positional arguments.

* gnu/packages/patches/d-feet-drop-unused-meson-argument.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add new entry.
* gnu/packages/gnome.scm (d-feet)[source]: Apply the patch.
---
 gnu/local.mk                                  |  1 +
 gnu/packages/gnome.scm                        |  5 ++-
 .../d-feet-drop-unused-meson-argument.patch   | 36 +++++++++++++++++++
 3 files changed, 41 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/d-feet-drop-unused-meson-argument.patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 18e8235140..68dfc21df1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1034,6 +1034,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/cvs-CVE-2017-12836.patch		\
   %D%/packages/patches/c++-gsl-find-system-gtest.patch		\
   %D%/packages/patches/c++-gsl-move-array-bounds-tests.patch	\
+  %D%/packages/patches/d-feet-drop-unused-meson-argument.patch	\
   %D%/packages/patches/date-output-pkg-config-files.patch	\
   %D%/packages/patches/datefudge-gettimeofday.patch		\
   %D%/packages/patches/dbacl-include-locale.h.patch		\
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7df18f055f..516c9f98d3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -76,6 +76,7 @@ 
 ;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
 ;;; Copyright © 2023 Juliana Sims <juli@incana.org>
 ;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
+;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -7199,7 +7200,9 @@  (define-public d-feet
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1jqw5ndpgyb0zxh0g21ai1911lfrm56vz18xbccfqm4sk95wwcw7"))))
+                "1jqw5ndpgyb0zxh0g21ai1911lfrm56vz18xbccfqm4sk95wwcw7"))
+              (patches
+               (search-patches "d-feet-drop-unused-meson-argument.patch"))))
     (build-system meson-build-system)
     (arguments
      (list
diff --git a/gnu/packages/patches/d-feet-drop-unused-meson-argument.patch b/gnu/packages/patches/d-feet-drop-unused-meson-argument.patch
new file mode 100644
index 0000000000..5d728d7d60
--- /dev/null
+++ b/gnu/packages/patches/d-feet-drop-unused-meson-argument.patch
@@ -0,0 +1,36 @@ 
+From 05465d486afdba116dbc22fc22c1e6573aea4f22 Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Mon, 24 Jan 2022 12:11:57 +0000
+Subject: [PATCH] meson: drop unused argument for i18n.merge_file()
+
+Ignored in Meson < 0.60.0, deprecated since 0.60.1 and fatal since 0.61.0.
+
+data/meson.build:15:0: ERROR: Function does not take positional arguments.
+data/meson.build:27:0: ERROR: Function does not take positional arguments.
+---
+ data/meson.build | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index 026bd80..3b03b94 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -13,7 +13,6 @@ desktop_in = configure_file(
+ )
+ 
+ i18n.merge_file(
+-  desktop,
+   type: 'desktop',
+   input: desktop_in,
+   output: '@BASENAME@',
+@@ -25,7 +24,6 @@ i18n.merge_file(
+ appdata = df_namespace + '.appdata.xml'
+ 
+ i18n.merge_file(
+-  appdata,
+   input: appdata + '.in',
+   output: '@BASENAME@',
+   po_dir: po_dir,
+-- 
+GitLab
+
-- 
2.39.2