diff mbox series

[bug#57017] : gnu: tdlib: Update to 1.8.4.

Message ID 86a68hgzfb.fsf@163.com
State Accepted
Headers show
Series [bug#57017] : gnu: tdlib: Update to 1.8.4. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Zhu Zihao Aug. 6, 2022, 3:30 p.m. UTC

Comments

Zhu Zihao Aug. 13, 2022, 2:04 p.m. UTC | #1
ping.
Ludovic Courtès Aug. 31, 2022, 10:57 p.m. UTC | #2
Hi,

Zhu Zihao <all_but_last@163.com> skribis:

>>From 0037a0f2847fe39846c5a03139ef1be5b0a45155 Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Sat, 6 Aug 2022 23:10:56 +0800
> Subject: [PATCH 1/2] gnu: tdlib: Use G-expressions.
>
> * gnu/packages/messaging.scm (tdlib)[arguments]: Use G-expressions.

[...]

>>From 45ff40bc27f6cacba976814841c90e8572118302 Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Sat, 6 Aug 2022 23:12:17 +0800
> Subject: [PATCH 2/2] gnu: tdlib: Update to 1.8.4.
>
> * gnu/packages/messaging.scm (tdlib): Update to 1.8.4.
> <#:configure-flags>: Enable LTO. Move build type settings to #:build-type
> arguments.
> <#:build-type>: Use "Release build".

Applied, thanks!

Ludo’.
Giovanni Biscuolo Sept. 9, 2022, 1:57 p.m. UTC | #3
Hello,

sorry I was not able to spot this issue before this patch was committed

Zhu Zihao <all_but_last@163.com> writes:

[...]

> From 45ff40bc27f6cacba976814841c90e8572118302 Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Sat, 6 Aug 2022 23:12:17 +0800
> Subject: [PATCH 2/2] gnu: tdlib: Update to 1.8.4.
>
> * gnu/packages/messaging.scm (tdlib): Update to 1.8.4.
> <#:configure-flags>: Enable LTO. Move build type settings to #:build-type
> arguments.
> <#:build-type>: Use "Release build".
> ---
>  gnu/packages/messaging.scm | 10 ++++------
>  1 file changed, 4 insertions(+), 6 deletions(-)
>
> diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
> index aa15bf5b53..89ba419f18 100644
> --- a/gnu/packages/messaging.scm
> +++ b/gnu/packages/messaging.scm
> @@ -2653,22 +2653,20 @@ (define-public telegram-purple
>  (define-public tdlib
>    (package
>      (name "tdlib")
> -    (version "1.8.0")
> +    (version "1.8.4")
>      (source
>       (origin
>         (method git-fetch)
>         (uri (git-reference
>               (url "https://github.com/tdlib/td")
> -             (commit (string-append "v" version))))
> +             (commit "7eabd8ca60de025e45e99d4e5edd39f4ebd9467e")))

with the change above this patch is not using an official release of the
library but a specific commit from master, still not stable

the last stable release of tdlib is still 1.8.0 [1] and there is no
1.8.4 release yet

unfortunately people (like me) who upgraded tdlib are now having
problems with emacs-telega (see bug#57543)

please revert this patch ASAP

furthermore, it is likely that reverting this patch is not enough to
restore emacs-telega functionality since the tdlib upgrade triggered a
tdblib database upgrade that is non more compatible with the previous
tdlib version (see bug #57543) for details

[...]

Happy hacking!  Gio'

[1] https://github.com/tdlib/td/blob/master/CHANGELOG.md
diff mbox series

Patch

From 45ff40bc27f6cacba976814841c90e8572118302 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 6 Aug 2022 23:12:17 +0800
Subject: [PATCH 2/2] gnu: tdlib: Update to 1.8.4.

* gnu/packages/messaging.scm (tdlib): Update to 1.8.4.
<#:configure-flags>: Enable LTO. Move build type settings to #:build-type
arguments.
<#:build-type>: Use "Release build".
---
 gnu/packages/messaging.scm | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index aa15bf5b53..89ba419f18 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2653,22 +2653,20 @@  (define-public telegram-purple
 (define-public tdlib
   (package
     (name "tdlib")
-    (version "1.8.0")
+    (version "1.8.4")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/tdlib/td")
-             (commit (string-append "v" version))))
+             (commit "7eabd8ca60de025e45e99d4e5edd39f4ebd9467e")))
        (sha256
-        (base32 "19psqpyh9a2kzfdhgqkirpif4x8pzy89phvi59dq155y30a3661q"))
+        (base32 "1chs0ibghjj275v9arsn3k68ppblpm7ysqk0za9kya5vdnldlld5"))
        (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (arguments
      (list
-      #:configure-flags
-      #~(list "-DCMAKE_BUILD_TYPE=Release"
-              "-DTD_ENABLE_LTO=OFF")      ; FIXME: Get LTO to work.
+      #:build-type "Release"
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'remove-failing-tests
-- 
2.37.1